Menu

LEX File Exchange
EA Support Files
SC4 Wikipedia
Network Addon Mod
Dependencies
Chat
Welcome, Guest. Please login or register.
Did you miss your activation email?

July 23, 2021, 06:25:12 PM

Login with username, password and session length

Author Topic: Railway not working  (Read 214 times)

0 Members and 1 Guest are viewing this topic.

Offline michealspencer

Railway not working
« on: June 14, 2021, 09:32:37 PM »
Hi, I have another rail station at the end of the rail that goes to a neighbor city so the passengers can get off in the residential area. But whenever I put a rail behind a rail station, nothing seems to happen and there is no usage of the rail system. I'm wondering why it doesn't work? Any ideas? Thanks

Offline BartonThinks

Re: Railway not working
« Reply #1 on: June 15, 2021, 09:09:24 AM »
I believe the two most likely answers are:

1) Your Sims don't need to travel in the direction that the railroad is going (e.g., they have jobs in a different direction), so they aren't taking the train.

OR

2) Your Sims are traveling in the direction of the railroad, but taking the train is not the quickest route. Because it's not the quickest route, they're choosing to drive instead.

Issue #2 was a mistake that I regularly made when I was first playing the game. I'd plop a rail station, expecting some of my Sims to convert to mass transit. However, because of the way I would lay out my railroads and streets, it was always faster for the Sims to travel by car. As a result, I'd end up with no passengers (or a tiny number of passengers) at these stations.

It's worth noting that rail layout isn't the only issue that causes this problem. Train travel requires Sims to walk to the station (or take the bus, or park and ride), which increases transit times. Also, any time that Sims switch from one type of transportation (e.g., walking) to another (e.g., train), it adds to the trip time. Car travel allows a direct A-to-B trip, so unless you lay out your railroad carefully or face long drive times due to congestion, Sims are inclined to travel by car.

Offline jeffryfisher

  • Uncle Jeff
  • Forums Councilmember
  • *
  • Posts: 72
  • Total likes: 63
  • Reputation: 0
  • The most local level of gov't is one citizen
    • Liberating Digital Content
Re: Railway not working
« Reply #2 on: June 15, 2021, 09:53:00 AM »
Hi, I have another rail station at the end of the rail that goes to a neighbor city so the passengers can get off in the residential area. But whenever I put a rail behind a rail station, nothing seems to happen and there is no usage of the rail system. I'm wondering why it doesn't work? Any ideas? Thanks
What do you mean by "nothing seems to happen"? Are you relying on visible trains (automata) to tell you the line is active? If too close to the edge of the map, then automata might not be visible, so don't rely on them. Use the route query tool.
 
What do you mean by "there is no usage of the rail system"? Are you saying that the route query and station stats report zero rail trips in that city?

Why do you expect trips to the neighbor city? Are there unfilled jobs there?

Finally, route-finding is very complex if there are even a couple alt routes, so here a picture really is worth a thousand words. Can you post a pic covering the rail, the station and nearest alt connection, all with the traffic volume heat-map turned on? It could illuminate any of several issues.
Modding PC games since 1993 (back when we needed hex-editors)