• Welcome to SC4 Devotion Forum Archives.

Arden Tree Controller Help Desk

Started by vortext, June 01, 2011, 06:42:21 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Pleased to hear that!  ()stsfd()

Personally I don't like dense forest everywhere either and hence developed the Inland controller for that reason. It's still my main controller to this day, albeit a heavily modified version of it.  :)
time flies like a bird
fruit flies like a banana


Another cool thing about the Arden Tree controller is that it creates natural grasslands in low to medium elevated areas.

Mikey Knox

How did you do that, mine just places nothing^^ Is this the Coast Extended one?


Yes, the extended versions contain various meadows (also alpine) where the regular version are just empty areas. Since the Inland controller was a bit of a afterthought at the time, and as said previously suited to my own wishes, I didn't bother with an extended version.

However, I made the controllers interchangeable so you could, for instance, revisit the area you showed with River Extended for cattails, poplar and the like along the shoreline. The River controller is even less forest dense btw.

All this tree controller talk, I'm tempted to look up the all HD controller files in the archives but there're already enough WIP folders on my desktop as is.  ::) :D

Thanks Vizoria, I really enjoyed seeing my work play a small part in your fabulous MD.  :thumbsup:
time flies like a bird
fruit flies like a banana

Mikey Knox


Hi, I'm experiencing some sort of issue with the tree controller

So I had been using CycleDogg's CTP07 controller for a while and recently got back into SC4, and with that I've been adding and changing mods. I changed tree controllers over to Columbus Terrain mod which worked fine, but then I wanted to try out Arden, as it seems to be the best tree mod available.  :)

However, I seem to be experiencing some kind of issue. I was running into some terrain/terraforming CTDs, which I can sometimes manage to not have crash by loading another tile first

When I can avoid terraforming CTDs I encounter another problem that seems to be related to the tree controller; I can place some small amounts of trees with the god tool, in small spurts or holding down the tool in the same small spot, but once I start to use the tool at a larger size or over a larger area, it CTD for seemingly no reason.  ()what()
I'm pretty certain I have all the dependencies; I mean if it was dependency based or something wouldn't it just be a brown box? What might cause this (these) issue(s)?
(I removed my rock mod as per PPond's readme. The only other thing I noticed was that the Arden readme listed the birch dependency filename as Grfe_props_pack_birches.dat, which doesn't exist: only Grfe_birches_summer, ..._seasonal, Grfe_props_pack_LE_birches, & ..._MM_birches exist)

It seems I can sometimes avoid this too, I believe by saving before using the tree brush - although it doesn't always help.
I had the least trouble with the River Extended version and the most with Inland
When testing out coastal extended, it seemed to be working fine, but then I terraformed a bit to get some different tree types, didn't save, and went to use the tree tool and it CTD again

Probably the most interesting part is that for all of these the time it takes for the tree brush to CTD is completely different, sometimes immediately, other times 8 seconds in, etc. Sometimes I can use it for multiple long instances and then it will crash after just half a second of using the tool again.

It makes it seem like a memory/CPU issue but it definitely isn't based off the number of trees already placed, and I haven't had this issue in the slightest with other tree mods.

I don't know really anything about how the code in SC4 mods work so I'm quite stumped; all I can do is trial and error. I guess I'll have to go back to Cascadia for now... it's ashame because this mod has a lot more variety and higher quality in flora.

Some info: running Steam version on Mac, using sudden valley terrain mod
I can certainly post more info as needed, such as Plugin folder, crash log, etc.

And here's some pictures I don't know if they'd be useful at all:


did you make sure to remove any tree planted with the previous controller before swapping?
I'll take a quiet life... A handshake of carbon monoxide.

Props & Texture Catalog


It's in a completely new region
That's supposed to be enough right?



Can you try it with only the tree controller and its dependencies inside your plugin folder(s) to see if it still does the same?
I'll take a quiet life... A handshake of carbon monoxide.

Props & Texture Catalog


Okay so I was able to remove everything except for SC4MacInjector (I believe it modified the game code because my game won't run without it. I posted to their tech issues thread to see how to uninstalling that before I have to reinstall SC4 itself)
With SC4MacInjector present it still does not work so I'm guessing it's because of that. I'll update here once I can test without mac injector; don't know how long till he'll respond to that thread, so I'll wait perhaps a day or two before I just try a fresh reinstall.


Okay... So I have read this thread but I still can't figure out an answer.  I use the Steam version of SC4.  I have using this tree controller for years with multiple devices.  About a week ago without any additional plugins added, I started having CTD while using the god mode tree brush.  I have taken out all the plugins except for the tree controller and it's dependencies and it still is crashing.  I have tried making it use one CPU but maybe I am not using it right.  Can anyone help me out?