Menu

LEX File Exchange
EA Support Files
SC4 Wikipedia
Network Addon Mod
Dependencies
Chat
Welcome, Guest. Please login or register.
Did you miss your activation email?

May 11, 2021, 02:36:48 PM

Login with username, password and session length

Author Topic: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE  (Read 1188459 times)

0 Members and 2 Guests are viewing this topic.

Offline fachriuwu

Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4660 on: January 09, 2021, 09:24:57 PM »
There's not anything in the One-Way Road Arrow Reduction Plugin that would affect the Road Turning Lanes.  What most likely would is if on the install, you forgot to check the Legacy Road Turning Lanes option in the installer (which isn't checked by default).  Reinstall, and make sure you have that box checked while doing so.

-Alex
solved thanks  :D

Offline mwerneburg

Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4661 on: January 18, 2021, 03:26:55 PM »
Hi! I've been enjoying NAM since it first came out. Dating to that first installation, I wound up with two of the Maxis subway buttons in the game. This I could ignore. But with the latest installation I have six of every Maxis transportation button: roads, streets, every form of highway, subways, etc. I've tried combing through the files to see if something was amiss but no luck.

I used the installer with a fairly conservative set of options. I have the GOG version of the game on Windows 10. I also have CAM installed.

Any thoughts on what I should do?

Thanks in advance,

Offline Tarkus

  • Administrator
  • Forums Legend
  • *
  • Posts: 11615
  • Total likes: 5639
  • Reputation: 74
  • NAM Team Tankadillo
    • NAM HQ
  • CL: Dr. PuzzlePiece
Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4662 on: January 18, 2021, 09:34:39 PM »
Hi mwerneburg, welcome to SC4D, and thanks for the kind words!

Doubled icons are the result of having two full copies of an icon exemplar.  They're unusual files, in that rather than overriding one another, they simply multiply, if multiple full copies of them exist.  NAM 39 does not contain any copies of the base networks' icon exemplars, so the most likely possibility is that you may have pieces of an old NAM installation around, or possibly multiple copies of SimCity_1.dat (which is where the original icon exemplars are located). 

If you merged files into SimCity_1.dat as part of CAM installation (which is part of the install process for CAM 2.1.0), and the backups are still laying out somewhere where the game might load them, that has the potential to cause such an issue.

There are ways to look up where duplicate files are stored . . . the most recent utility I know of is SC4DataNode by rivit.  It's also possible to do using the Plugins Analyser tool in ilive's Reader, which has been around in some form for a very long time.

If it helps in finding them, the hex info for the icons is that they're Type 0x6534284a, Group 0x2a3858e4, and all have Instances in the 0x0000002# range.  Here's the full list of Instance IDs (IID)--finding one of these should find the rest:

  • Road: 0x00000020
  • Elevated Highway: 0x00000021
  • Rail: 0x00000022
  • Subway: 0x00000023
  • Avenue: 0x00000024
  • Light Rail (Elevated Rail): 0x00000025
  • Street: 0x0000002A
  • One-Way Road: 0x0000002B
  • Ground Highway: 0x0000002D
  • Monorail: 0x0000002E

Hope that helps!

-Alex

Offline nickWtn

Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4663 on: February 11, 2021, 08:45:08 PM »
So this might have been broken on NAM 38 but I didn't notice it until NAM 39 but there seems to be something wrong with the QuickTurn type 220 x 220 T intersection like northbound turn lanes don't seem to be lining up with the intersection (hopefully that makes sense) anymore, I also feel like there use to be a puzzle piece for this in the Tuelps list which I might have been using but no longer see as well anymore either.. anyways  I have what it should look like from another intersection in my city and what It looks like now in NAM 39. 

Offline Tarkus

  • Administrator
  • Forums Legend
  • *
  • Posts: 11615
  • Total likes: 5639
  • Reputation: 74
  • NAM Team Tankadillo
    • NAM HQ
  • CL: Dr. PuzzlePiece
Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4664 on: February 13, 2021, 08:44:44 AM »
Thanks for the report . . . given that the FTLs haven't been modified at all since their debut, that's actually a NAM 36 issue.  I've been able to replicate it and some other issues.  Strangely, the issue isn't as bad if you're building the intersection manually with the base FTLs rather than using QuickTurn--a couple of the rotations still mess up a little, but they're fixable by clicking around, which can cause the RUL2 code to behave again.  I'm going to take a further look into it, though, to see how easily I can get it to work 100% as intended.

As far as the TuLEPs go, none have been removed, though that whole side of things has been relegated to "Legacy" status, since we're gradually trying to push old-style puzzle pieces into obsolescence to the greatest extent possible, and the FTLs are able to do everything TuLEPs could.  The TuLEPs never had any puzzle pieces to support T-intersections involving the Type 220 setups.  The only two intersections that involved Type 220 in the old TuLEPs set were the Type 220 x 120 +-intersection and the Type 220 x 220 +-intersection.

-Alex


Offline dyoungyn

Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4665 on: February 13, 2021, 08:42:50 PM »
Here is one that I am having problems with NAM 39.  This is a 7.5 M Slope RHW6C over RHW 10S.  No mater how many different times I try this approach, always the same result.  I never had this problem with NAM36.  Only if there was a NWM6 over RHW this could resolve RHW over RHW.

Offline Tarkus

  • Administrator
  • Forums Legend
  • *
  • Posts: 11615
  • Total likes: 5639
  • Reputation: 74
  • NAM Team Tankadillo
    • NAM HQ
  • CL: Dr. PuzzlePiece
Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4666 on: February 14, 2021, 02:19:30 AM »
That'll be fixed with NAM 40.

-Alex

Offline dyoungyn

Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4667 on: February 14, 2021, 07:43:14 AM »
Alex,

Thank you for the reply. 

Thank you to the entire NAM team for all these great and fabulous NAM creations. 

I guess the only work around is to go the other way, the RHW 10S over NWM 6 instead.

Offline nickWtn

Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4668 on: February 15, 2021, 06:41:57 PM »
Thanks for the reply Alex, turns out the reason I was confused and thought that stuff was missing was that when looking for the 220 x 220 T intersection in the ftl list after I found that's what it's called in the quick turn list I assumed it would be called that and not the 120x2 + Avenue/TLA - 5 with default layout , It also probably didn't help that to me at least looking at the preview of the 120x2, that is looked to be to small lane count wise to fit the intersection. Anyways thanks for the help again.

Edit: well ok nope even with the 120x2 I'm still can't get that intersection to work, it keeps reverting to the other version with the messed up sidewalk
                                                                         
« Last Edit: February 15, 2021, 06:54:37 PM by nickWtn »

Offline dyoungyn

Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4669 on: February 17, 2021, 04:55:24 PM »
And yet here is another problem/bug with NAM39.  I cannot make this work no mater how many times I try.  It is RHW10S over RD3 at which the road gets crossed under the overpass.  The slope is 7.5

Offline nickWtn

Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4670 on: February 19, 2021, 07:35:09 PM »
well dang, it I found another texture issue.. I assume the sidewalk should be on the other side of the AVE-4 to AVE-2 transition? oh it's up against the country club reward.

Offline Tarkus

  • Administrator
  • Forums Legend
  • *
  • Posts: 11615
  • Total likes: 5639
  • Reputation: 74
  • NAM Team Tankadillo
    • NAM HQ
  • CL: Dr. PuzzlePiece
Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4671 on: February 20, 2021, 05:47:09 AM »
The ARD-3 has a tendency to be an unrepentant jerk at times--the tricky thing about it (and particularly coding it) is that it's inexplicably exactly backwards of the RHW-3.  I'll take a look to see if I can find where the issue is, but if it's going to be an involved fix, then it'll have to wait until a planned NWM code revamp to get fixed, since I don't want to spend a whole bunch of time writing/fixing code that's going to be going in the trash bin shortly thereafter.

I'll note, we have internally floated the idea of actually reversing the direction of the ARD-3.  There's a few ways we could accomplish that.  Finding the one that requires the least transition for the existing userbase would be the priority.

As far as that sidewalk issue goes, are you using the puzzle piece or the draggable option?  The puzzle piece relies on a rather temperamental exploit to get the wealth textures/sidewalks/grass, and it'll glitch out like that if touching a Low Density zone of some sort.  That's a known issue with the puzzle piece, and if you're using that instead of the draggable option, I'd recommend switching to the draggable.

-Alex

Offline nickWtn

Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4672 on: February 20, 2021, 08:24:02 PM »
Umm if that question is for the intersection iím using the FLEX Turn Lane - Dual-Tile FlEx T-Intersection from the FIL menu so I guess the puzzle piece version. Also oddly enough and I donít know why or how this hasnít worked today but it seems that unlike before me clicking with the roads starters on the either the westbound or estbound lanes changes the wealth texture (I hope thatís what itís called) and fixes the intersection.. again no clue why it hasnít done that before but well at least that works as a workaround.

Offline Tarkus

  • Administrator
  • Forums Legend
  • *
  • Posts: 11615
  • Total likes: 5639
  • Reputation: 74
  • NAM Team Tankadillo
    • NAM HQ
  • CL: Dr. PuzzlePiece
Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4673 on: February 21, 2021, 06:35:07 AM »
The question was about the AVE-4-to-AVE-2 transition.  FTLs are, by definition, not puzzle pieces, as they're FLEX-based (TuLEPs are the puzzle piece equivalent).  "Clickaround" (i.e. clicking around a broken RUL with a network tool) will sometimes cause things to correct themselves, which is an indication that there is some good code there, but there's some bad code that's interfering with it.

-Alex

Offline nickWtn

Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4674 on: February 23, 2021, 12:52:59 PM »
Oh ok umm yeah I used the puzzle piece one in transitions. I just tried the draggable one and that fixed it, thanks for the suggestion on that, Alex. 

Offline ackalbo

Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4675 on: March 17, 2021, 12:56:07 AM »
One Tile Roundabout Issue

Hello everyone. I've just recently started playing again and yesterday was playing around with NAM 39.  Everything is great and a huge thank you to all involved.

I just can't seem to get the One Tile Road/Road Roundabout to work...











I have fully installed NAM39 and to my knowledge the only option I changed was to LHD and European Textures...

Any suggestions would be greatly appreciated.



Offline Tarkus

  • Administrator
  • Forums Legend
  • *
  • Posts: 11615
  • Total likes: 5639
  • Reputation: 74
  • NAM Team Tankadillo
    • NAM HQ
  • CL: Dr. PuzzlePiece
Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4676 on: March 18, 2021, 03:48:59 AM »
One Tile Roundabout Issue

Hello everyone. I've just recently started playing again and yesterday was playing around with NAM 39.  Everything is great and a huge thank you to all involved.

I just can't seem to get the One Tile Road/Road Roundabout to work...

I have fully installed NAM39 and to my knowledge the only option I changed was to LHD and European Textures...

Any suggestions would be greatly appreciated.

I've just investigated the issue--it's an LHD-only issue.  I'm currently exploring a couple of possible solutions to it, attempting to figure out which one will work best.  It will be fixed for NAM 40.  (Edit: I now have my solution working as of a few moments ago, so I can officially 100% confirm this improvement for NAM 40.)

Also, nickWtn, I've added some more code to cover that situation with the FTL/QuickTurn Type 220 x Type 220 T-intersection.  The fix there will be incorporated in NAM 40 as well.

-Alex

Offline ackalbo

Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4677 on: March 18, 2021, 12:49:53 PM »
I've just investigated the issue--it's an LHD-only issue.  I'm currently exploring a couple of possible solutions to it, attempting to figure out which one will work best.  It will be fixed for NAM 40.  (Edit: I now have my solution working as of a few moments ago, so I can officially 100% confirm this improvement for NAM 40.)

Looking forward to NAM40 already  ;D
Keep up the excellent work, it's all very very much appreciated.

Offline soulchaser

  • Forums Governor
  • *
  • Posts: 389
  • Total likes: 0
  • Reputation: 0
  • Don't take me too serious
Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4678 on: April 02, 2021, 05:12:23 AM »
I did some search but could not figure out if this was reported before...
I seem not to be able to drag L1 RRW diagonally over a road. There seems not to be any model for the crossing. Is this right? (using the new NAM 40 updated on a fresh install of NAM39)

It pops down to L0 crossing. It works fine with L2, though.

Thank you for your astonishing work with the NAM.

Recently Iced

You might also visit my participitation in GRVII - Bordertown!

Offline Tarkus

  • Administrator
  • Forums Legend
  • *
  • Posts: 11615
  • Total likes: 5639
  • Reputation: 74
  • NAM Team Tankadillo
    • NAM HQ
  • CL: Dr. PuzzlePiece
Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4679 on: April 03, 2021, 05:05:03 AM »
The L1 RRW x Road DxO is indeed not supported at present.  To my knowledge, L2, surprisingly enough, is (the ERRW development thus far focused more on L2, mainly to render the existing puzzle pieces obsolete quicker).

-Alex