Menu

LEX File Exchange
EA Support Files
SC4 Wikipedia
Network Addon Mod
Dependencies
Chat
Welcome, Guest. Please login or register.
Did you miss your activation email?

June 15, 2021, 01:36:35 AM

Login with username, password and session length

Author Topic: Game not loading  (Read 2617 times)

0 Members and 1 Guest are viewing this topic.

Offline deanva

Game not loading
« on: February 27, 2018, 03:01:50 PM »
When I have tried to launch game from Origin the screen is black no cursor or anything. I can not get the task manager to open or no response at all, tried running as administrator same problem. Do I have to uninstall Origin and download new? It has worked in the past on the same computer Windows 10 system maybe something got deleted by accident i am out of ideas.
« Last Edit: February 27, 2018, 03:05:16 PM by deanva »

Offline fantozzi

Re: Game not loading
« Reply #1 on: February 28, 2018, 03:43:44 AM »
As I don't have the origin version and not own win10 I can only refer to what I've been reading.

The Origin Version doesn't include the latest fixes done by EA (patches back in 2003) which amongst others fixed several graphic issues - so could lead to the problems you described.

Over here, third post in this thread, describes your issue, I think:

https://community.simtropolis.com/forums/topic/74232-simcity-4-deluxe-origin-version-unpatchable/


Offline mgb204

Re: Game not loading
« Reply #2 on: February 28, 2018, 08:50:02 AM »
Whilst the Origin version is problematic because of the update issue, that shouldn't actually prevent the game from running.

The symptoms here are the classic ones that come from use of Windows 10, where the drivers needed to validate the on-disk DRM are missing. SC4 opens, fails to validate, then closes without warning. If that's the case, I would uninstall all versions of SC4 from your machine and then re-install the Origin one only. Because it would suggest you've an older disk-based copy still installed that's conflicting with the digital release.

The only other causes of a working game to cease functioning would be if either the install became corrupted/broken, which again would need a re-install to fix. Otherwise, perhaps your graphics card drivers have been updated and are no longer compatible with SC4. In which case switching to software rendering should get SC4 going again. Usually this is done by adding the line:

-d:software

To the target line of SC4's shortcut (accessible by right clicking the shortcut and selecting properties). However, if you are launching from the Origin client, you will need to add this line elsewhere or it won't be invoked, I'm sorry but I don't know how to do this with Origin. Although I believe you can make a shortcut that runs SC4 directly from either the desktop or start menu.

Offline dyoungyn

Re: Game not loading
« Reply #3 on: February 28, 2018, 02:39:34 PM »
I agree, only the digital version I was able to load and works even better with Windows 10 and I have the Pro version. 

I tried the old disk version, but I concur with mgb204, some issue with Windows 10 and loading from disc.  This is thus the reason, I still have my old Windows XP laptop with only 2 cores for other older games such as Rome Total War working smoother and great.

Games today require one to be on-line with enhanced graphics and mods and based off my basic understanding, Windows 10 with multiple cores just cant decide which one to use and causes issues. 

Things were so much better with Windows XP and with a CD drive installed.

Offline mgb204

Re: Game not loading
« Reply #4 on: February 28, 2018, 02:47:50 PM »
No offense, but it's not my opinion that Windows 10 won't allow the disk version to load, it's a fact. MS themselves released an announcement they were removing SafeDisc support from Windows 10, they then released updates for Win Vista-8.1 editions that did the same thing. This is not unique to SC4 and affects potentially thousands of games using this technology (DRM) from around that time. Which just goes to show how even the lightest touch DRM is still a big deal.

Offline deanva

Re: Game not loading
« Reply #5 on: February 28, 2018, 04:44:58 PM »
I contacted Origin and they gave me steps to do and game is working again I had to delete something execpt a local content folder. However my regions I made are not showing up under the start up manager or any of my custom lots in lot editor. Not sure how to get them to work again they are on the computer because i have found them.


Offline mgb204

Re: Game not loading
« Reply #6 on: February 28, 2018, 05:15:26 PM »
Did you delete the SimCity 4 folder in Documents? That contains all your plugins and regions. Check if those files are still there, if so SC4 should see them.

Otherwise it would be helpful to see the steps you followed with Origin, just to have an idea of what exact changes were made.

Offline dyoungyn

Re: Game not loading
« Reply #7 on: February 28, 2018, 06:40:35 PM »
I personally have incidents where a finished map just does not load for some reason upon using backup both Regions and plugins.  It is one or two maps and not really an end game for me and I just re-do the map.