Menu

LEX File Exchange
EA Support Files
SC4 Wikipedia
Network Addon Mod
Dependencies
Chat
Welcome to SimCity 4 Devotion. Please login or sign up.

August 14, 2022, 04:48:34 PM

Login with username, password and session length

Downloads

Three Rivers Region

Started by dedgren, December 20, 2006, 07:57:49 PM

Previous topic - Next topic

0 Members and 3 Guests are viewing this topic.

deathtopumpkins

Sorry about your flights David. Today just doesn't seem to be anyone's day. My car gave out on the interstate 40 miles away earlier today.

And I'm not sure about other people, but I got the files the first time.  :)

Off to try to break the STR again.
NAM Team Member | 3RR Collaborater | Virgin Shores

nerdly_dood

#6021
Quote from: dedgren on December 21, 2008, 02:46:25 PMI spent about 45 minutes trying to get today's STR bug fix/update files out, and still don't know if they made it to everyone. 

I received no fewer than three of your emails today ;)

EDIT: Ok so now I've actually done some testing with the STR, assisted greatly by UDI.

I had some slope trouble starting the new rail line so i could transition it to STR after the HSR line:


Due to the RHW incompatibility I had to use a short avenue section here:


After that i had some trial-and-error to get this to look smooth as I took it out of that city tile:


At this point I took a freight train through it, which worked well, but when it went into one of the curves, the 45 curve i think That was the S-curve - the tank that caused the spill was at the end of the 45 curve., the train suddenly stopped, but its speed meter thing was still where it was, so I held down my E key and the train crashed as they tend to do at high speeds - without moving. Murphy's Law held true here and I had a toxic spill nowhere near any roads for the fire department to access it:


But the paths appear fine:


I tried it again in another section, and the train worked beautifully until i came to another S-curve (different rotation) and I had the same problem.

I figured that I was done with that city, so I went into the one I'd connected to, and took a track nearly straight through the tile, with one road crossing and one bridge, but since the crossing and bridge were 3 tiles offset from the connection I had a little fun connecting them:


I tried to UDI another freight train through that one, but it promptly vanished when it came to where the rails crossed - because there were no paths:

I guess that explains the huge lags I had building the loopy thing.

EDIT: n_d, my friend- I have a theory about what causes the tanker derailment/explosion problem.  I should have seen it coming, as I wondered what would happen when I pathed the piece.  More about this tomorrow.  Thanks! -DE
My days here are numbered. It's been great and I've had a lot of fun, but I've moved on to bigger and better things.
—   EGO  VOBIS  VADELICO   —
Glory be unto the modder and unto the fun and unto the city game!

sithlrd98

I also received 3 e-mails today...was wondering what the deal was . Good to hear you finally landed (safely) and have already posted my newest bug on previous page.

Jayson

Gaston

So far this is my only problem.   But I'll keep looking.  (evil laugh)    Sorry about the tool bar but this is my favorite test city and I forgot to turn it off.






---Gaston
白龍

They say that the memory is the second thing that goes....
...dang , I wish I could remember the first.
WooHoo made Councilman - 05 FEB 07 Yipee made Mayor - 13 MAR 07 Hip Hip Hooray made Governor - 04 AUG 07 Rock On made Senator - 15 MAR 09

metarvo

#6024
I haven't really played with STR much yet, but I'm not FARR from doing just that.  $%Grinno$%

Anyway, here's another round of test pics.

POSITIVES

#1

By playing around with a variation of the workaround I illustrated earlier, I have created a "FAR" grid.  This grid interacts with an orthogonal street system.  The transitions between FAR and ortho road are abrupt in several places, since there was not sufficient room for the normal ortho-FAR transition.

#2

This is an example of how these wonderful Christmas presents David has given us can be used to create a winding, anti-grid rural road.  Since I am putting all of this trouble into building this network, I am saving all of the work I put into it.

NEGATIVES

#3

Unfortunately, the FAR pieces don't always get along with each other.  It seems as though the different FAR pieces must be placed in a particular order so that they can be placed next to each other.

Sadly, it seems as though the NAM 45-degree Avenue curve suffers from the same problem as the RHW when these new items are installed.  :(  Additionally, the workaround I posted earlier works only for FAR, not FARR.  So, there are currently no FARR neighbor connections.

EDITI'm working the FARR neighbor connection issue, as we (Jonathan (Warrior), actually) made changes that removed the capability.  That one should be fairly easy, I think. -DE
Find my power line BAT thread here.
Check out the Noro Cooperative.  What are you waiting for?  It even has electricity.
Want more? Try here.  For even more electrical goodies, look here.
Here are some rural power lines.

bwatterud

Just got through some "breaking stuff" testing.  In addition to the lack of paths on the draggable switches, I came across an issue like Gaston's but on a (probably) more common setup. 

dedgren

Just one more post before bed.

Beta testers, check this out in this next update, in your email box shortly.



Game rail will never be the same again!

* * *

metarvo, my friend- I have a bunch of FAR intersection textures "in my pocket."  Those should, along with some additional curve pieces, make a FAR "grid" entirely doable.  The problem is not how, it's when.

* * *

Brad (bwatterud) and Al (Gaston)- For right now, others are doing the non-puzzle piece parts of the STR.  Hopefully we'll have a convo tomorrow and nail down all the pathing issues, as I don't have anything along that line in the update just going out now.  It's great that you folks are pointing those glitches out, as it would take weeks for a couple of guys to find them.

G'night, all!


David

196403
D. Edgren

Please call me David...

Three Rivers Region- A collaborative development of the SC4 community
The 3RR Quick Finder [linkie]


I aten't dead.  —  R.I.P. Granny Weatherwax

Skype: davidredgren

BigSlark

#6027
David,

I'm amazed by the STR so far. I was about to go test today's alpha when I saw your new post...

Sadly, this is a very busy week for me, but that's life at a Christian Church in the days leading up to Christ's birth, huh?

Cheers,
Kevin

Edit: For clarity's sake, its not only my faith, but my day job as well.

dedgren

Kevin, not sad at all.  It sounds like your priorities are completely appropriate for the season.  I'm just one of those spinning plate guys...


All rights reserved in original copyright holder

...trying to keep, with varying degrees of success, it all in the air at once.  I admire your willingness to place a priority on your faith.


David

196427
D. Edgren

Please call me David...

Three Rivers Region- A collaborative development of the SC4 community
The 3RR Quick Finder [linkie]


I aten't dead.  —  R.I.P. Granny Weatherwax

Skype: davidredgren

Pat

I am having a bit wierd problem when trying to test with my plugins folder!!! I go in game I start to do some work, start to lay some track and then game lock up on me...  I dont know If I am having computer issues but also having other problems with the computer but that is for another thread siiiiiiiiiiiigh  :'( ()sad()

oooh BTW Kevin I admire you sir!!!

Don't forget the SC4D Podcast is back and live on Saturdays @ 12 noon CST!! -- The Podcast soon to Return Here Linkie

gardenwong

one more little test............
I tried to use the left hand drive in the test but it isn't work.....
so....finally I turn back to use right hand drive to test the STR.....
below is some of the test:


most of the road cross-over......it's nothing wrong if you cut the rail in 90 degrees
but if you cut the rail in 45 degrees or 135 or 235 or 225 or 315.......the raill will turn back into double track...




also....the raill level-crossing.....



it seems that most of the train will use the double track but not the STR.....althought the STR track is faster and shorter to let people go to work.....



also...some problem on building a switcher .......


and can't choose which way to go in the UDI.......
俺がã,¬ãƒ³ãƒ€ãƒ ã wwwwww

sim-al2

#6031
@David: I know we're supposed to break the STR, but mine's so broken I can't even put any pictures. I get the accursed "## Intersection Placement String Missing ##. I tried plopping a piece, and it actually didn't crash. but I got a textureless (and presumbly non-functional) patch of nothing with three rail stubs. It occurs with all pieces. Was the latest file in the email at 6:00 P.M. only a update? %bur2$

Nevermind. Got it working after some playing around with the first email and updates. :-[ -sm2
(\_/)
(o.O)
(")_(")

Toichus Maximus

Well, here is what I've been doing.






Also, my research has revealed this broken path:



Cheers!
Matt

sithlrd98

Yeah, I already noticed that on previous page...I have received newest and will try to continue breaking it! ;D

Jayson

un1

All of the errors I noticed have been reported...

I will do more testing when the next file comes out.
Looking pretty good so far!  &apls

-un1

debutterfly

I don't know if this has been fixed with the Dec 22 fixes but with Dec 21 rev01 i could not get the SLRxSLR Crossing Orthagonal to render. there was no texture file for it.

When I get home from work, I will test the latest revision.

Larry (debutterfly)

sithlrd98

Report time: The new pieces (diag S and FARR to diag )work fine..no problems placing or connecting. :thumbsup:
Noticed I have 2 instances of STR straight & diag fillers , the STR-STR crossing still has no path , the STR dragable splitter still has no paths , of course there is no texture for STR-SAM crossings...yet(just reporting what I see , cosmetic or not), and since my post #6017 has probably been buried , I'm also noticing , and I'm just pointing anything and everything I see , various puzzle pieces are not here yet as I have a few ***placement string****or whatever showing as others have already stated.

With each update , the overall placement and connection of pieces (with paths) has gotten quicker and seem to work very well. I have yet to check the UDI , but the paths etc. look fairly straight and work.

Jayson

sim-al2

Intial report coming in.

I've been doing a lot of breaking so far, and I've come across some damage to other puzzle piece menus.

#1. The rail puzzle piece has been devastated. Bad pieces fill the menu, and I'm not sure what pieces are missing so far, but I think it may be 2x diagonal pieces.

#2. GLR-in_Avenue has two invalid pieces at the end of the menu.

#3. FARR icon is repeated twice.

Post is under construction, pending pictures. -1:02 UTC
(\_/)
(o.O)
(")_(")

dedgren

#6038
Okay, okay.  I'm getting a sense that some of you may have completely hosed your NAM directories trying to follow my directions in the daily updates as I've added and deleted folders and files.  That's my fault- if you are a beta tester and are having no problems with missing and corrupted stuff, IGNORE THE FOLLOWING.

Okay, for those few who (hopefully) I haven't run off, navigate to your "Network Addon Mod" folder in your My Documents directory.

Delete the "STR" subfolder and its contents.  Delete the "Switches" subfolder and its contents.  Delete the "WRC-Country_Roads-FAR-FARR" subfolder and its contents.  Delete the "Additional Wide Curves and FARR" subfolder and its contents.  You should now have the same NAM folder you did when all this started.

Now, unzip folders and files in the following DL [download linkie] to your desktop or to a "Temp" folder.  Doubleclick to open the "Network Addon Mod rev 081222-02" folder, and you'll see this.



Now, move the controller file and all the folders into the "Network Addon Mod" folder in your My Documents directory.  Click yes when you are asked to overwrite the existing controller file.

That's it, you're done.

I'm finishing up those puzzle pieces.


David

197094
D. Edgren

Please call me David...

Three Rivers Region- A collaborative development of the SC4 community
The 3RR Quick Finder [linkie]


I aten't dead.  —  R.I.P. Granny Weatherwax

Skype: davidredgren

sithlrd98

#6039
Done. Now I'm off to try and break something.

Jayson

Edit 1 ...the above link is missing str_base.dat so you'll be missing the draggable textures.

Edit 2... I have no idea whats up now , I hadn't had any major problems before but now I'm missing other textures...






Jayson

Edit again...after checking the updated updated file I see the problem.looks like I didn't see all of the missing .dats! Thanks David!