Sim City 4 Devotion Forums

SimCity 4 Devotion Welcome Portal => LEX File Exchange Discussion => LEX Development Centre => Topic started by: CasperVg on November 12, 2013, 12:46:47 AM

Title: SC4D LEX Bug & Issue Reports
Post by: CasperVg on November 12, 2013, 12:46:47 AM
Please post bugs and issues that you encounter while using the SC4D Lot Exchange in this thread. That way I can keep track of all of them easily. When posting, please include the following details to make it easier to reproduce the bugs:

Operating system
Browser (+ version)
Screen/window size/resolution

However, this thread is not for people having trouble logging in or activating their account. For those problems, please use this thread (http://sc4devotion.com/forums/index.php?topic=232.0).
Title: Re: SC4D LEX Bug & Issue Reports
Post by: Jack_wilds on February 19, 2014, 03:37:13 PM
I am having serious issues with the LEX for teh passed 3 weeks... as I am unable to log correctly even when it says I am being loged on... then I am blocked from all features even though i am logged on... I have done all I know to do cleaning out the cache... changing passwords...
Title: Re: SC4D LEX Bug & Issue Reports
Post by: CasperVg on March 21, 2014, 02:05:22 AM
@ Jack_wilds: Please let me know your browser, operating system and screen resolution. Most likely you are using an old browser that is not supported by the LEX anymore.
Title: Re: SC4D LEX Bug & Issue Reports
Post by: Jack_wilds on March 21, 2014, 02:55:58 PM
CasperVg

here is data concerning my laptop...
I have the latest version of Firefox 28.0
Explorer is also up to date

Driver Version:      8.15.10.1892

Operating System:      Windows 7 Home Premium* , Service Pack 1 (6.1.7601)
Default Language:      English
DirectX* Version:      11.0
Physical Memory:      2936 MB
Minimum Graphics Memory:   128 MB
Maximum Graphics Memory:   1340 MB
Graphics Memory in Use:   47 MB

Processor:      Intel64 Family 6 Model 23 Stepping 10 GenuineIntel
Processor Speed:      2094 MHZ

Accelerator in Use:
      
Mobile Intel(R) 4 Series Express Chipset Family

Video BIOS:      1659.0
Current Graphics Mode:   1366 by 768 True Color (60 Hz)
Title: Re: SC4D LEX Bug & Issue Reports
Post by: vester on April 01, 2014, 07:37:34 AM
Noticed that the images on the detail pages are mirrored.
(http://i.imgur.com/57vKWY9.jpg)
Title: Re: SC4D LEX Bug & Issue Reports
Post by: CasperVg on April 01, 2014, 01:00:20 PM
It should fix itself at midnight ;)
Title: Re: SC4D LEX Bug & Issue Reports
Post by: threestooges on April 01, 2014, 02:49:10 PM
You amuse me, Casper. I like it.
-Matt
Title: Re: SC4D LEX Bug & Issue Reports
Post by: vester on April 01, 2014, 03:30:48 PM
It should fix itself at midnight ;)

Good one. ;)
Title: Re: SC4D LEX Bug & Issue Reports
Post by: Jack_wilds on April 01, 2014, 05:25:09 PM
on another april fool note... issues concerning LEX log-in still continues  &mmm
Title: Re: SC4D LEX Bug & Issue Reports
Post by: CasperVg on April 02, 2014, 02:27:13 AM
I'm sorry for that, Jack_wilds. Judging by your computer specs and browser version, everything should be working smoothly. I've developed (and used) the LEX in Firefox 28 and everything works fine. Are you sure you don't have any firefox plugins that disable cookies or javascript?
Title: Re: SC4D LEX Bug & Issue Reports
Post by: Jack_wilds on April 02, 2014, 06:56:59 PM
not that I am aware of...  it is frustrating for this has worked fine no issues when suddenly, the log-in began giving fits of noncooperation... the LEX update also worked fine... simply do not know what the hang-up could be... all privledges are grayed or unseen... access to 'log-out' unseen unavailable... its a head scratcher...
Title: Re: SC4D LEX Bug & Issue Reports
Post by: Girafe on May 24, 2014, 11:59:19 AM
when an uploader update a picture on the LEX, this one is not showing a let a blank
Title: Re: SC4D LEX Bug & Issue Reports
Post by: CasperVg on May 24, 2014, 12:55:58 PM
I've just tested updates pictures on the LEX and as far as I can see everything seems to working fine. It could be that your browser has cached the old image (especially if you used the same name for the new picture) and will continue to display it for some time (it's trying to save bandwidth by not requesting images that it has already downloaded before). If you clear your browser cache the image should change to the updated version.
Title: Re: SC4D LEX Bug & Issue Reports
Post by: Girafe on May 25, 2014, 02:10:21 PM
Cache has been cleared many times

(https://dl.dropboxusercontent.com/u/19293845/Capture%20d%27%C3%A9cran%202014-05-24%2019.57.52.png)
Title: Re: SC4D LEX Bug & Issue Reports
Post by: Varnado on June 15, 2014, 10:50:54 PM
I'm no longer able to search by uploader on the LEX! The search function is only displaying 15 results for me no matter what. This is hugely inconvenient, as now I can't find a lot of mods I was looking for! Is anybody else able to get more results from the power search page (http://sc4devotion.com/csxlex/lex_search_00.php)?

If this in fact isn't a bug but rather a feature that was added recently, please reconsider restoring the full functionality of the search. As it stands it's more or less impossible to find lots of uploads from prolific content creators like SimGoober unless you already know the name of each individual download.
Title: Re: SC4D LEX Bug & Issue Reports
Post by: Tarkus on June 15, 2014, 11:41:05 PM
It does show more than 15 results.  If you're using a script blocker like NoScript (as I do), you'll need to allow scripts from sc4devotion.com and bootstrapcdn.com.  The additional listings will show once you scroll down to the very, very bottom.  A little notification that it's "loading more results" will pop up at the very bottom, and then another set of results will appear below the first ones.

You may also want to try the Lot Table option under the search menu--I've been using it religiously since it was implemented, and it definitely shows more than 15 results.  You can just type in the name of the uploader into the appropriate field.

-Alex
Title: Re: SC4D LEX Bug & Issue Reports
Post by: catty on June 16, 2014, 05:30:25 AM
...The additional listings will show once you scroll down to the very, very bottom.  A little notification that it's "loading more results" will pop up at the very bottom, and then another set of results will appear below the first ones....

Sometimes when you do that, there will be a brief delay before it brings up the next lot, but otherwise I've never had any problems with it   :)

....As it stands it's more or less impossible to find lots of uploads from prolific content creators like SimGoober unless you already know the name of each individual download.

That was one of the reasons I started the Catalog, so everything regardless of the site could be looked up in the one place

See here for the Catalog

http://city-builders.info/index.php/catalog

ToutSimcities will be added soon, as the Catalog doesn't list the plugins in title order just by the order it was entered into the Catalog, the second part of the Catalog is here

http://city-builders.info/index.php/tags

-catty
Title: Re: SC4D LEX Bug & Issue Reports
Post by: Varnado on June 16, 2014, 05:14:50 PM
It does show more than 15 results.  If you're using a script blocker like NoScript (as I do), you'll need to allow scripts from sc4devotion.com and bootstrapcdn.com.  The additional listings will show once you scroll down to the very, very bottom.  A little notification that it's "loading more results" will pop up at the very bottom, and then another set of results will appear below the first ones.

You may also want to try the Lot Table option under the search menu--I've been using it religiously since it was implemented, and it definitely shows more than 15 results.  You can just type in the name of the uploader into the appropriate field.

-Alex
The lot table is an acceptable workaround but this is really weird. I'm still only getting 15 results from the power search, and the additional listings are not loading when I scroll to the bottom of the page. I was able to get it to work just fine as recently as a week ago and it's been broken since yesterday. Sure there were no updates to the LEX in that time?

I have a feeling this may also be a Chrome issue, since the additional results loaded fine just now when I tried a couple searches in Firefox. Google does tend to break lots of things in unannounced updates. (And no, I haven't had a script blocker enabled for SC4D since I discovered the site.) Regardless of the root cause of the problem, it definitely does exist and is quite inconvenient.

---

Alright, I just tried installing the latest update to Chrome (v35) after writing the above two paragraphs (took like 15 minutes to reload all my tabs because my residential Comcast connection has in the last few weeks gone from OK to complete rubbish and constantly blips out for some reason, also doing so disabled all of my non-web store extensions and apparently I'm not allowed to reenable them unless I switch to a dev release or a fork :bomb:) and it didn't fix anything but I'm getting some seriously weird behavior. The additional results are loading maybe 5% of the time, but never when I search for uploads by SimGoober or CP and always when I search for uploads by gascooker. Something has clearly gone wrong here.
Title: Re: SC4D LEX Bug & Issue Reports
Post by: Indiana Joe on June 16, 2014, 07:40:53 PM
It does show more than 15 results.  If you're using a script blocker like NoScript (as I do), you'll need to allow scripts from sc4devotion.com and bootstrapcdn.com.  The additional listings will show once you scroll down to the very, very bottom.  A little notification that it's "loading more results" will pop up at the very bottom, and then another set of results will appear below the first ones.

You may also want to try the Lot Table option under the search menu--I've been using it religiously since it was implemented, and it definitely shows more than 15 results.  You can just type in the name of the uploader into the appropriate field.

-Alex
The lot table is an acceptable workaround but this is really weird. I'm still only getting 15 results from the power search, and the additional listings are not loading when I scroll to the bottom of the page. I was able to get it to work just fine as recently as a week ago and it's been broken since yesterday. Sure there were no updates to the LEX in that time?

I have a feeling this may also be a Chrome issue, since the additional results loaded fine just now when I tried a couple searches in Firefox. Google does tend to break lots of things in unannounced updates. (And no, I haven't had a script blocker enabled for SC4D since I discovered the site.) Regardless of the root cause of the problem, it definitely does exist and is quite inconvenient.

---

Alright, I just tried installing the latest update to Chrome (v35) after writing the above two paragraphs (took like 15 minutes to reload all my tabs because my residential Comcast connection has in the last few weeks gone from OK to complete rubbish and constantly blips out for some reason, also doing so disabled all of my non-web store extensions and apparently I'm not allowed to reenable them unless I switch to a dev release or a fork :bomb:) and it didn't fix anything but I'm getting some seriously weird behavior. The additional results are loading maybe 5% of the time, but never when I search for uploads by SimGoober or CP and always when I search for uploads by gascooker. Something has clearly gone wrong here.

I'm always running the latest Chrome and haven't had any LEX problems.  Try updating things like Flash Player, Java, etc. and try turning on/off addons (Adblock, etc.)

That third party extension crap is ridiculous though.  Hopefully they'll change it back in the next update, they're getting plenty of complaints from power users.
Title: Re: SC4D LEX Bug & Issue Reports
Post by: CasperVg on June 17, 2014, 02:43:45 AM
Quote
That third party extension crap is ridiculous though.  Hopefully they'll change it back in the next update, they're getting plenty of complaints from power users.

The problem isn't that we are blocking third party extensions (we're not), the problem is that certain third party extensions are blocking the LEX functionalities. Extensions like NoScript, Ghostery, etc. by default block all JavaScript running on websites. That is usually done for privacy purposes (to avoid being tracked by Google, Facebook, etc. all over the internet with tracking scripts). However, the LEX doesn't use (and won't use) any of these scripts, which means you're not getting tracked.

So please, disable (or whitelist us on) those extensions to get the full LEX experience. Unfortunately I'm not a fulltime paid developer (it's all spare-time free work), so I don't have the time to develop workarounds for people who wish to disable Javascript on their browser).
Title: Re: SC4D LEX Bug & Issue Reports
Post by: Varnado on June 17, 2014, 07:36:15 PM
That third party extension crap is ridiculous though.  Hopefully they'll change it back in the next update, they're getting plenty of complaints from power users.
Agreed 100% but I won't hold my breath. Sometimes you just have to submit your complaint to the right channel and take the bad with the good, especially when it comes to updates from Google and the specter of widespread security issues. It's not like there weren't already plenty of good reasons to keep multiple browsers/versions installed.

The problem isn't that we are blocking third party extensions (we're not), the problem is that certain third party extensions are blocking the LEX functionalities. Extensions like NoScript, Ghostery, etc. by default block all JavaScript running on websites. That is usually done for privacy purposes (to avoid being tracked by Google, Facebook, etc. all over the internet with tracking scripts). However, the LEX doesn't use (and won't use) any of these scripts, which means you're not getting tracked.

So please, disable (or whitelist us on) those extensions to get the full LEX experience. Unfortunately I'm not a fulltime paid developer (it's all spare-time free work), so I don't have the time to develop workarounds for people who wish to disable Javascript on their browser).
I already said before that I don't block JavaScript or anything like that for SC4D. But just in case, I tried disabling all of my extensions and restarting again and I'm still getting the same very strange behavior I described in my last post. I have the most current updates I can get for Java and Flash Player too. Anything else you can think of on my end that might be causing this?
Title: Re: SC4D LEX Bug & Issue Reports
Post by: Indiana Joe on June 17, 2014, 08:03:12 PM
The problem isn't that we are blocking third party extensions (we're not), the problem is that certain third party extensions are blocking the LEX functionalities. Extensions like NoScript, Ghostery, etc. by default block all JavaScript running on websites. That is usually done for privacy purposes (to avoid being tracked by Google, Facebook, etc. all over the internet with tracking scripts). However, the LEX doesn't use (and won't use) any of these scripts, which means you're not getting tracked.

So please, disable (or whitelist us on) those extensions to get the full LEX experience. Unfortunately I'm not a fulltime paid developer (it's all spare-time free work), so I don't have the time to develop workarounds for people who wish to disable Javascript on their browser).

I was not talking about the LEX, I was referring to the Google Chrome project. As Varnado mentioned, they disabled third-party extension functionality in the last Chrome update; Chrome users can now only download extensions through the Chrome Web Store.  It's an Apple-esque move, and very frustrating.  It's a completely separate issue from the LEX; it just came up in the discussion.    :thumbsup:
Title: Re: SC4D LEX Bug & Issue Reports
Post by: Girafe on August 30, 2014, 03:53:13 PM
Uploader tool => my files doesn t display "my files" but the last files uploaded by everybody  ::)
Title: Re: SC4D LEX Bug & Issue Reports
Post by: vester on October 21, 2014, 04:30:50 PM
Was about to report the same.

Please bring it back.
Title: Re: SC4D LEX Bug & Issue Reports
Post by: Shadow Assassin on December 05, 2014, 11:31:48 PM
I consider this a serious bug:

You are apparently sending passwords with login details via plain text using a GET request. This is a serious security flaw and really should be fixed as soon as possible.

Use POST instead, and the query string should be an encrypted hash.
Title: Re: SC4D LEX Bug & Issue Reports
Post by: JoeST on December 06, 2014, 06:18:37 AM
Using POST is no more secure, and having to hash it client side relies on javascript which is just as easily circumvented. The forum will only be sending your password in plaintext (over POST, but still), and so will 99% of other websites you use. I agree that that's a major flaw, but its a flaw with the web, not with how Casper is doing stuff, and yeah Casper could do better, but I don't think client-side hashing (at least on the web) is secure enough to be worth it. I'd suggest a much better way of making it secure is using https, at least for the login page.
Title: Re: SC4D LEX Bug & Issue Reports
Post by: Shadow Assassin on December 06, 2014, 07:38:20 AM
No, I agree it's no more secure but it is still security through obscurity, which isn't really security by definition but it's something at least. As for hashing, a salted hash generated upon login (by the server) should be secure enough.

Or you know, why not implement something like OpenID?

I just don't like seeing my password being broadcast using a GET request. The web is by definition insecure, but anything that we can do to make the web more secure is welcome. ;)
Title: Re: SC4D LEX Bug & Issue Reports
Post by: CasperVg on December 06, 2014, 08:27:17 AM
We are working to improve the situation, but the LEX is big and most of it is not programmed very well, so changes like user authentication can take awhile to get done, especially if you want to do it right. I'll do a few small tweaks in the meantime that should improve the situation at least a bit. Hopefully we can install some ssl/https certs as well, so that all LEX communication can be secured against eavesdropping as well.

EDIT: Login GET has been changed to login POST. Not a huge improvement, but it's something at least for now.
Title: Re: SC4D LEX Bug & Issue Reports
Post by: memo on December 16, 2014, 02:38:57 AM
All comments on the LEX seem to be missing. It says 0 comments for me in the comment section of each upload, some of which I know for sure had comments. Tested in Chrome and Firefox.

Edit: Oh well, I found the "old comments" link for the nostalgic at the bottom When does a comment classify as old though? The latest comment on the LEX is three days old and is hidden, too. How about showing the last 10 comments with an option to load the rest?
Title: Re: SC4D LEX Bug & Issue Reports
Post by: Girafe on January 09, 2015, 06:04:37 AM
I follow Memo regarding the comments, it would be nice to bring them back.

Something else, in the last release, 2 were locked but it displays LEX CERTIFIED in red, should be LEX NOT CERTIFIED in orange or LEX LOCKED in red.

There is somewhere the list of LEX certified people, I have a doubt that catalyst is LEX certified uploader but I am maybe wrong.
Title: Re: SC4D LEX Bug & Issue Reports
Post by: c.p. on January 09, 2015, 10:37:59 AM
Also, "Recent Comments" (under "Uploader Tools") is not showing the latest comments.  Which means the only way to check if there have been any problems posted to any of my recent uploads is to check the comments for each upload individually.  Which is not really feasible.  Fortunately, there are so few comments posted on the LEX now, there is a fairly good chance they will pop up as one of the random comments.  So I guess it's not a big deal for now. &mmm
Title: Re: SC4D LEX Bug & Issue Reports
Post by: CasperVg on January 10, 2015, 06:23:49 AM
I was hoping to make people comment more often by switching to the Disqus-based system, but it appears that experiment failed. Everything has been reverted to the old comment system.

There is no public list of LEX Certified uploaders. It should display "Locked / Unavailable" now instead of LEX Certified.
Title: Re: SC4D LEX Bug & Issue Reports
Post by: CasperVg on January 10, 2015, 06:32:04 AM
Also, some of you might be happy to know that "My Files" works again for certified uploaders.

EDIT: And files with images higher than 188px will now show their thumbnail again (in search results), instead of the full (long) image.