LEX File Exchange
EA Support Files
SC4 Wikipedia
Network Addon Mod
Welcome, Guest. Please login or register.
Did you miss your activation email?

January 23, 2022, 08:39:35 AM

Login with username, password and session length

Author Topic: Problem with the SC4DatPacker 2008 on Windows 8 [SOLVED]  (Read 5142 times)

0 Members and 1 Guest are viewing this topic.

Offline MandelSoft

  • The Dutch Freeway Engineer
  • NAM Team
  • Forums Guru
  • *
  • Posts: 3969
  • Total likes: 15
  • Reputation: 30
  • SimCity 4 turned me into a civil engineer
  • CL:
    Let there be Light!
Problem with the SC4DatPacker 2008 on Windows 8 [SOLVED]
« on: December 02, 2012, 04:39:30 AM »
Hello everyone,

I have a problem with the SC4 DAT Packer and it seems that it doesn't work on my Windows 8 PC. Everytime I try to start up, it gives the following error:

Code: [Select]
Traceback (most recent call last):
  File "datPackerApp.pyo", line 2749, in OnClose
  File "datPackerApp.pyo", line 2755, in ShowMain
  File "datPackerApp.pyo", line 2559, in __init__
KeyError: 'folder'

I've installed the enlisted DLL-files in the readme and yet it refuses to work, to my frustration.

Can anyone replicate this issue and if so, does anyone know how to fix it?


EDIT: Problem already solved. It seems that config.ini was messing it up. Deleting it did the trick.
« Last Edit: December 02, 2012, 05:59:53 AM by MandelSoft »
Lurk mode: ACTIVE