Menu

LEX File Exchange
EA Support Files
SC4 Wikipedia
Network Addon Mod
Dependencies
Chat
Welcome, Guest. Please login or register.
Did you miss your activation email?

December 04, 2021, 05:22:20 PM

Login with username, password and session length

Author Topic: SC4T Not Responding  (Read 3524 times)

0 Members and 1 Guest are viewing this topic.

ChiefZDN

  • Guest
SC4T Not Responding
« on: April 29, 2017, 01:00:16 AM »
Hello everyone,

I already installed the Terraformer in my laptop that's run Ubuntu 16.04 and lastest Wine from distro's repo. However, when I ran, it freeze and doesn't respond to clicks and keyboard presses (pressing ALT doesn't work). Can you fix this problwm?

Thank you.

Offline mgb204

Re: SC4T Not Responding
« Reply #1 on: April 29, 2017, 03:16:10 AM »
Open the install directory of Terraformer, find the file readme.html and rename it to literally anything else. If that doesn't solve your problems, perhaps you are missing one of the required resources (libraries) needed for the application to run?

ChiefZDN

  • Guest
Re: SC4T Not Responding
« Reply #2 on: May 11, 2017, 01:30:08 AM »
Open the install directory of Terraformer, find the file readme.html and rename it to literally anything else. If that doesn't solve your problems, perhaps you are missing one of the required resources (libraries) needed for the application to run?

It look like in the attachment. Black window content and can't clicked. This problem is persist even I was migrated to new laptop with new installation, too. The Wine version: 1.6.2 on Ubuntu 16.04. My laptop is using mobile Intel HD 3000.
« Last Edit: May 11, 2017, 01:33:40 AM by ChiefZDN »

Offline mgb204

Re: SC4T Not Responding
« Reply #3 on: May 11, 2017, 04:16:54 AM »
Driver issue or simply not supported by Linux properly would be my guess then.

If it helps any, the software runs under the Python language. From a rendering perspective, I'd put money on it being OpenGL based.

Offline Handyman

  • Forums Citizen
  • *
  • Posts: 50
  • Total likes: 38
  • Reputation: 1
  • We are all astronauts living on the same spaceship
Re: SC4T Not Responding
« Reply #4 on: May 11, 2017, 06:24:17 AM »
Did you notice on the Stex page that you may need to install DirectX and MSCVP71.DLL into the wine prfix where SC4 is installed?

ChiefZDN

  • Guest
Re: SC4T Not Responding
« Reply #5 on: May 12, 2017, 07:38:48 PM »
Did you notice on the Stex page that you may need to install DirectX and MSCVP71.DLL into the wine prfix where SC4 is installed?

I don't notice it. Where is the page specifically?

Thanks, I'll use it. I'll send my report soon.

Out of topic: My Mapper also sent an error during exporting and sometimes freeze. Maybe, this is caused by same problem too.
« Last Edit: May 12, 2017, 08:14:49 PM by ChiefZDN »