Menu

LEX File Exchange
EA Support Files
SC4 Wikipedia
Network Addon Mod
Dependencies
Chat
Welcome to SimCity 4 Devotion. Please login or sign up.

May 19, 2022, 09:03:56 AM

Login with username, password and session length

Downloads

Sc4 Terraformer on Windows 7 32 bit

Started by End_of_Eternity, September 21, 2010, 12:50:27 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

End_of_Eternity

Hi guys,

I've been trying to get SC4 Terraformer to run on Windows 7, but with no luck.

The splash screen loads up and then it asks me to select my region folder. After nothing happens and the process just stays in Task Manager without any UI popping up.

Here are the content of the log file:
Traceback (most recent call last):
  File "SC4TerraformerApp.pyo", line 2369, in OnClose
  File "SC4TerraformerApp.pyo", line 2372, in ShowMain
  File "SC4TerraformerApp.pyo", line 624, in __init__
  File "DlgCities.pyo", line 206, in __init__
  File "DlgCities.pyo", line 310, in RebuildConfig
ZeroDivisionError: float division

Can anyone explain to me what is going on?

I've installed the latest dx dist and even manually reinstalled the April 2006 cab file contents. I've added MSVCP71.DLL and gdiplus.dll to my system32 folder. I've check that every single dll file in SC4 Terraformer's readme is present in the system32 folder. I've tried running the Terraformer exe in both XP SP2 and SP3 compatibility mode. The exe has admin rights.

I don't know what else to try any more.

Thanks!

manchou

I've got Window 7 x64 and i have same error  &mmm i d'ont know if it can open on Window 7 32 or 64 Bits ...
My BATs or here but it is in french ;)

Andreas

I can't remember if I installed anything special, but SC4Terraformer seems to work fine on my Win7 64 bit. It doesn't show up in the taskbar before opening a region, though, and the window where you can select one is often hidden behind the browser that pops up with the readme file. Also, I disabled UAC, maybe that's a possible solution to solve your problem.
Andreas

End_of_Eternity

UAC is disabled. That's the first thing that I do when installing NT 6.0+.

I actually got SC4 Terraformer running last night. The reason why it wouldn't load was because I pointed it to folder without a config.bmp file. Now SC4T runs, but I can't get it so save region. I point to a folder with my config.bmp file, load the greyscale PNG, but when I hit save nothing happens.

It works when click on create region and create a new region from the greyscale, but then it loads a default config.bmp and its 16x16 small cities, which is not what I want.

Any suggestions guys?

Lowkee33

I dont know what the actual problem is, but here are some things.

Cant SC4 already render greyscale?  Maybe you can render and then open it in terraformer to do some tweaking.

Perhaps you can change the default config?

I have also found it best to wait until the splash screen is done (and folder options come up) before I move the mouse or do anything.

Good luck, hopefully someone who knows will post.


Andrew_C

I am running Win 7 64 have exactly the same issue. Gave the SC4TF executable admin rights, running it in XP SP3 compatibility, with themes and composition disabled. I Have dx9c installed & msvccp71 installed, even put copies of gdiplus.dll & msvcp71.dll in the sc4tf directory.

It starts, asks for the regions folder and then disappears but is still sitting in memory and I have to kill it from Task Manager.

This is the SC4Terraformer.exe.log file

Traceback (most recent call last):
  File "SC4TerraformerApp.pyo", line 2369, in OnClose
  File "SC4TerraformerApp.pyo", line 2372, in ShowMain
  File "SC4TerraformerApp.pyo", line 624, in __init__
  File "DlgCities.pyo", line 206, in __init__
  File "DlgCities.pyo", line 310, in RebuildConfig
ZeroDivisionError: float division

gumbie


Andrew_C

No, I am not. SC4T comes with a copy of msvcr71.dll

Lowkee33

#8
Sorry Andrew_C (and End_of_Eternity for that matter), dll errors have been asked so many times that I overlook things:

QuoteZeroDivisionError: float division

You opened an empty folder.  You need to put a config.bmp in there so Terraformer will form a map.

Edit: It is a flaw that you need a region to create a region.  Anyway, I always have a small 1x1 region in my folders to give something to Terraformer when I want to make a new region.  Once the program has loaded, then you can do "create region" and load up an SC4map file.

Andrew_C

Thanks! SC4TF is running now. Now I just have to figure out out to use it.

How do you export a greyscale PNG? the export 16 bit png option just gives me a black png.

Lowkee33

I looks all black, open it in photoshop and increase the contrast.  That is just the difference between the 256 brightness levels of a jpeg and the 65,536 levels of a 16bit png.  As far as I know, you can't import a 16bit PNG directly into SC4 (via Ctrl-Alt-R), you need to use Terraformer.

Andrew_C

Thanks, I was wanting to export the greyscale PNG to edit in another program as i am unfamiliar with SC4T's tools.

Lowkee33

At least it's working.  I'd imagine you can look around other threads for more info about map editing.  Just make sure your program can save 16bit PNG, GIMP can't (by default, I think there is a plugin that lets you).  Right tool for the job, Terraformer is designed for SimCity, and it's 3D editing environment is tough to beat.  If you have to cut/paste an island 32 pixels to the left, yeah, Photoshop is the tool for that.

Vanderzee1991

 :angrymore: Same problem, but different to the log file than everyone else here.  :angrymore:

Traceback (most recent call last):
  File "SC4Terraformer.py", line 1, in ?
  File "zipextimporter.pyo", line 78, in load_module
  File "SC4TerraformerApp.pyo", line 3, in ?
  File "zipextimporter.pyo", line 91, in load_module
ImportError: MemoryLoadLibrary failed loading tools3D.pyd <-------- (this is way different..)

help! :'( :'( :'(

Andrew_C

#14
Sorry to ask, but do you have MSVCP71.DLL and Directx9c installed?

I'm pretty sure I got the

ImportError: MemoryLoadLibrary failed loading tools3D.pyd

error before I realise I didn't have MSVCP71.DLL on this system

Latest DirectX End-User Runtime Web Installer: http://www.microsoft.com/en-us/download/details.aspx?id=35 WARNING! It will download about 150 megabytes of stuff.

A copy of MSVCP71.DLL that works with SC4T: http://www.dll-files.com/dllindex/dll-files.shtml?msvcp71 (download the zip file NOT the DLL fixer program). You can just drop the dll it in the SC4T directory.

If you don't want to download dll's from strange websites you quite probably have a copy sitting in Program Files somewhere if you have a lot of stuff installed, run a search for it.