Menu

LEX File Exchange
EA Support Files
SC4 Wikipedia
Network Addon Mod
Dependencies
Chat
Welcome to SimCity 4 Devotion. Please login or sign up.

May 19, 2022, 09:24:58 AM

Login with username, password and session length

Downloads

Problems with editing a MEGA PACK (solved)

Started by Lowkee33, November 09, 2010, 08:19:41 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Lowkee33

Hi all,

I have been editing CP MEGA Pack Vol 01 today.  My problem is that even though I can place all of the props in PIMX, they don't appear in SC4.

  The first thing I did was remove all of the Building/Prop Families property.  I then added that property back to every prop at a value of 0x00000000 (so that I could see them in the analyzer).  Then I changed the Building/Prop property to values that made sense (all of the cars with like cars....).  There were also a few timed props that I edited so that I could make families out of them.  I then re-indexed and rebuilt the directory.

Is there something that I am missing?  In a test I placed a non-timed, non-family prop on a lot, and that only appeared at one zoom.  I went through the S3D and FSH files and they appear to be intact.

Thanks

Andreas

Hard to tell without seeing the exemplar files - if the model is only visible at one zoom level, the "AppearanceZoomsFlag" property might have been modified improperly.
Andreas

Lowkee33

#2
"AppearanceZoomFlag" values appear okay.  Mostly 0x1e and 0x1f with a few stranger ones.  I haven't isolated when that problem happens, but I did for the families.

Here is my process:

I split CP vol_01 into two files: The models and the exemplars.  Everything still worked.  I made all of the props "previewable" and still fine.  I removed all of the Family properties to get a clean slate.  I then added the Family property back to every prop with a value of 0x00000000.  This family works in game.

When I change the family of the cars back to their original they no longer work.  The family will not appear at all, but if the car is selected individually it does appear in all zooms and rotations.

Edit:  It looks like I found the problem.  :-[  It seems that the default "Rep" Value for a Family is "0".  By changing this to "1" at least my first family worked (now I am not too sure why 0x00000000 worked...)

Well that wont be too bad to fix.  Now I just hope the timings are right :)

Andreas

Ah yes, I stumbled over this REP thingy as well (and probably not only me ;) ). Glad you found the problem!
Andreas