LEX File Exchange
EA Support Files
SC4 Wikipedia
Network Addon Mod
Welcome to SimCity 4 Devotion. Please login or sign up.

March 21, 2023, 01:03:00 PM

Login with username, password and session length


SC4 Startup Manager v3

Started by Andreas, June 09, 2007, 01:10:51 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Quote from: Rayden on June 10, 2007, 07:39:16 AM
Nice work Andreas and JLP, if this could work in conjunction with SC4DatPacker, it would be even better. JLP and Woua could join forces together and release a joined version &idea
I think there is no known conflict using SC4SUM and DatPacker. You can build different compressed folders and then use SC4SUM to select the one you want to use ( of course this require more HD space to hold multiple compressed folders )

Good job JLP, especially with the config.bmp maker  :thumbsup:

New Horizons Productions
Berethor ♦ beskhu3epnm ♦ blade2k5 ♦ dmscopio ♦ dedgren ♦ emilin ♦ Ennedi ♦ Heblem ♦ jplumbley
M4346 ♦ moganite ♦ Papab2000 ♦ Shadow Assassin ♦ Tarkus ♦ wouanagaine
Divide wouanagaine by zero and you will in fact get bad-ass that is - Alek King of SC4


I have downloaded the new startup manager and personally I think its great but (there is always a but) I cannot get it to run the game itself.

I have read the read me ( backed up previous version etc ) and been through the help files but no matter what I do It will not start. Even following your trouble shooter has not helped.

I find the programs hangs while loading. You say to try to "reconfigure the File System Control Manager" by editing the "Sumhkmodule.ini" file _How do you do this and what do you edit it to?  When I click the link it gives me the FSCM configuration page. ()what()  this stuff goes right over my head  ()what()

Quote "If a region profile is selected, SimCity 4 will be started automatically as soon as the appropriate plugin files are hidden.

If a development profile is selected, SimCity 4 will not be started. Instead there is button (between the buttons ,,change to main window..." and ,,minimize to system tray..."), which can be used to run any development application." unquote

This is as far as I get. If I close this window which seems to be loading the "Development " profile even though I have not activated it There is another one running "behind it" . It is as if I have to close it twice.

Any help wold be appreciated



Kettle's on. Milk? Sugars?    ps I don't like Earl Grey  $%Grinno$%
Reduce, Reuse, Recycle - If you're not part of the solution , you're part of the problem!
"Never knock on Death's door: Ring the bell and run away! Death really hates that!"
Tales at TeaTime      Now A proper NUT      TTC plays GRV II


The "Sumhkmodule.ini" can be found in the installation folder of the SUM. Just double-click the file and it will open with Notepad. You will find several settings, which are explained in the readme file. Mine looks like this, for instance:

FileControlMethod=sumnjserver, sumfmserver

You can try to change the order of the method (put "sumfmserver" in front of "sumnjserver") and start the SUM again, this might fix the issue.


This looks great Andreas, and I will install it. Thanks for your work and helping out making our lives (playing Simcity) that little easier.


Someone in the French Forum is having problems so I have translated his post and would be grateful if someone can answer his problem:
QuoteI installed the last version of the SUM but it is impossible to launch the game. I saw that there is  a subject devoted on Devotion there but I do not speak English well enough to explain my problem.
When I try to launch the play starting from the bar of my region, I obtain the following window (that where there are three possible views). But when I click on the bar of a profile or a city (in the other views), my computer crashed and I obtained a blue screen. I tested with the option mode window checked and and not checked, with and without plugins, but I always obtain the same result.
I also tried to change the order of the "FileControlMethod" in the "sumhkmodule.ini". In this case, I do not have a crash and I obtain the window "File System Control Server". But, although the green arrow indicates "running" and that my plugins is also marked by arrows in my explorer, nothing other occurs.
Having used the preceding version of the SUM, I hope that somebody will be able to help me to solve this problem to be able to use this version which seems me to be a small jewel.
Inside every old person is a young person wondering what happened. TP

Barbypedia: More alive than the original


Thank you Barby. I didn't look into the French forum. I hope I've answered understandable.


It seems clear enough to me, but then I am English ;D The translation works, though.
Inside every old person is a young person wondering what happened. TP

Barbypedia: More alive than the original


no skyscrapers in rural areas! nice! I'll use this on my other computer. pretty much devoted to jsut sc4
The most astounding and unique aspect of the human race is our fervent application of our ingenuity to kill each other, thus completely defying the near-universally proven fact that the ultimate goal of a member of a species is to ensure the survival of the species.


MY antivirus just went nuts regarding a file MadCHook.DLL during the install of SUM3.  Is this normal, my searches on google allude to spyware risks.   Please advise.


I don't know about the internal DLLs of the SUM, but most likely, this file is part of the System File Control Manager (SFCM) that hides the files from SC4 (and Windows) before the SC4 Startup. Apparently, your Antivirus software assumes this is a threat to the system. You don't need have to worry, though, the files are hidden only when the SFCM is running, and even if the service crashes for some reason, they should be unlocked again after restarting Windows.


As Andreas wrote, the "File System Control Manager" hides the deselected files (this is how the individual folder selection works). The DLL you refer to is one of the core modules that are responsible for this hiding process.


And according to McAfee Antivirus' library:

QuoteThe AFXrootkit trojan uses a third party library to achieve its stealthing. The 4382 DATs incorrectly identify a legitimate DLL (madCHook.dll 108,544 bytes) as trojan or variant AFXrootkit.dll.gen . This will be suppressed in the 4383 DAT release.

Source: AFXrootkit.dll.gen
New Horizons Productions
Berethor ♦ beskhu3epnm ♦ blade2k5 ♦ dedgren ♦ dmscopio ♦ Ennedi
emilin ♦ Heblem ♦ jplumbley ♦ moganite ♦ M4346 ♦ papab2000
Shadow Assassin ♦ Tarkus ♦ wouanagaine


I was wondering if there is a way to copy profiles???  I want to use a major profile for a region, but change it slightly city to city.  Can this be done, or do I have to check all those checks endlessly?????
Pamela K Wild

"The only way to decorate is with an unlimited imagination...and budget!"


Yes, you can copy profiles. Please refer to the included help file, which should explain the process.


Andreas, is the SUM compatible with windows vista? when i put in my new puter it crashes the windows explorer when i use it to run te game.


It should be compatible; however, I don't have Vista, so I can't tell it for sure. There's a troubleshooting guide in the help file as well, try the suggestions that are mentioned there.


Hi there! This seems to be a bit off the grid topic, but still, I managed to ignore this tool until today. But now, I'm given no choice but to use it. =) Here's another but. It won't start. It says SC4 is not installed, now I'm not, that much of a dummy that I wouldn't know the problem is in the instalation (I instaled it a while back on a seperate disk partition and another OS). I know the sollution of this problem (reinstaling thegame) but does someone know if I can make the tool or the game find themselves, so that I would ''trick'' the tool that I ''installed'' the game, eventhough I don't and evethoguh I already have it installed.

Thank you for the reply!


The SUM reads the SC4 path from the registry, so apparently, it's missing in your installation. Usually, reinstalling SC4 is the best way to fix that.