• Welcome to SC4 Devotion Forum Archives.

The RTMT V3 Support Thread

Started by z, September 10, 2008, 07:43:03 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


The 4th version of RTMT is under development, but V3 is the one currently released.

This thread exists to answer all questions concerning RTMTV3 usage, or report errors.  Please check the RTMT Frequently Asked Questions thread first, as well as the ReadMe file if you have already installed RTMT.  (The ReadMe file can be found in your Plugins folder, usually under STEX_Downloads\Cogeo\RTMTV3.)  If your question is still not answered, feel free to ask it here.  Also, if you have found a particularly interesting way to use RTMT stations that has not been described before and that you would like to share with others, this is the place to do that as well.  And if pictures help, definitely include them if you want!


HI all.

I would like to give my 1-cent opinion about RTMT, since I've heared that, maybe, a 4th version is next to be released.

Now I'm trying version 3.5 and is just great, but I have to complain about 3 things:

1 - the fact that all files are into a RAR archive complicates a bit my life: I would like to have a setup.exe utility and then use a read-me to remove some files that I may NOT want.

2 - There is one thing that I miss a lot from version 2.0: in that version, I was able to click once on the desired the MT stop icon from the menu and then I could "plop" them as parks, filling all my streets and avenues, without the need to click again on the menu and icons. Instead, with version 3.5 I can only click on icon, plop the MT stop and then I see that my cursor is "empty" as if I have plopped a landmark or a reward and so I have to re-click on the menu, select the same MT stop, place again; come back to the menu and so on... it is not a problem if you have to place very few of them, but since I really use them very much, I think that it is very important.

3 - I'm not very fond of the 1x1 box to make those icons to show up in the menu. If I have RTMT installed is because I want to use them!! But maybe there are some players that use it less than me, so...

That's all :)


Orion.. regarding #3 of your concerns.. are you using the MML? Because I think I read somewhere were that is a side-effect of the MML. I don't know for sure because I don't use MMLs

Henrik Sedin: 82gp 29g 83a 112p - 2009/2010 Art Ross/Hart Trophy winner!


Of course, I'm talking about the Menu Management Lot, that I don't like very much. I would like to be free to use those Mass Transit stops without being forced to build it first. But I don't have any brown box in the game :) Are we talking about the same thing? :)


Maybe I can help you with your points:

1. There is an executable version of the setup file.  You can find it here.

2. The behavior that you desire should be the way it works.  Does this problem happen with all types of stations?

3. This problem is easily fixed; just remove the MML plugin.  Its name is RTMTV3__MML.dat, and it should be in the top level RTMTV3 folder.


My guess is that you simply need to search for it and remove the lot, and that alone should do it... In fact, that -may- help with that click-each-time bug, as I suppose the MML makes it think the RTMT are unlockables. Now, I'm completely untechnical, but that's just my wild guess.  ;D


Oop, Z beat me to it with the file and all.
Visit my MD Respublikii Anaksii , or the reboot CJ "Kara`i Shores" since the region wiped, at http://www.simtropolis.com/cityjournals/?p=toc&id=919 !
All comments are welcome! (Hopefully someday I can re-splice 'em together, but we'll see)


thanks! I have another question: the previous trouble has been fixed but now I cannot place any subway station on street/roads avenues. I have to demolish se square upon which I want to build my stop. Is it normal?


Unfortunately this is not possible to be fixed. If you click on any "subway" lot, the game switches to underground view and you can't plop the lot on the road. You have to buldoze the road tile first.


Hmm, i thought that was only my problem... Cool, my computer's gotten one degree closer to normal!
My days here are numbered. It's been great and I've had a lot of fun, but I've moved on to bigger and better things.
Glory be unto the modder and unto the fun and unto the city game!


Strangely enough, I don't have this problem, nor did I ever.  I just verified this by plopping a plain subway station on two roads, one with a subway line underneath and one without.  In both cases, the station demolished the existing road, plopped, and then connected up with both ends of the adjoining road.  (The subway line was similarly reconnected.)  So it appears that either there's some combination of configuration settings within RTMT causing this problem, or the presence or absence of some external plug-in.

As cogeo noted, the view did switch to underground view upon selection of the station, but this did not prevent me from plopping it on an existing road.  More precisely, it switched to subway station view, which is slightly different from underground view, but is what you get in a vanilla game when you choose the Maxis subway station.  Subway station view is like normal view, except that all the subway lines are visible, and all roads are shown much more transparently.  Are you all seeing this when you select your stations?  If not, do you see it when you select the Maxis subway station?

@Orion79:  Were you previously able to plop subway stations on roads before you removed the MML (which I'm not using)?  And have you done anything else to modify your installation?

One more question for all three of you having this problem:  Which installation method did you use to install RTMT, the ZIP files, or the automatic installer?


I used the scripted installer program.

I use the prop families, the Euro textures with no road markings, and I have the GLR-in-avenue stations installed. I have the CAM capacity settings since I, uh, have the CAM installed.
My days here are numbered. It's been great and I've had a lot of fun, but I've moved on to bigger and better things.
Glory be unto the modder and unto the fun and unto the city game!


I would bet that both cogeo and Orion79 are using the Euro textures as well - I'm using the U.S. ones.  If that's true, this would be a likely possibility to investigate.  Cogeo and Orion79, can you confirm which textures you are using?

EDIT: I just did a little experiment myself, and replaced all the US files with UK/Euro files.  No effect at all.

@Orion79:  Did you have this problem with subways before?  If not, what else did you change besides MML?


I had the same problem with the American textures before I switched to Euro also... The texture change didn't affect the plop difficulty.

My days here are numbered. It's been great and I've had a lot of fun, but I've moved on to bigger and better things.
Glory be unto the modder and unto the fun and unto the city game!


I ran another experiment.  I ran SC4 from a fresh account, using absolutely no plug-ins except RTMT.  Once again, absolutely no trouble plopping subways on roads.  So it wasn't some funny plug-in of mine that was allowing me to do this.

If someone with this problem could do the corresponding experiment on their machine, the results would be very useful.  On a vanilla SC4 system, with only RTMT installed, do you still see this problem?

Also, what OSes are you people using?  Games in general, and SC4 in particular, have been known to be sensitive to the OS being used.

Finally, I'll be very interested in Orion79's answer to the question I asked above, as it may hold the key to the problem.


I'm back: when this thread as been moved, i've forgot to re-subscribe so I didn't get any notify of new replies.

Anyway, yes: I do use European textures for roads and I've used the automatic installer, without the MML.
The strange thing is that I am usign the old RTMT 2.1 mod too and I have no problems at all in plopping subway stations on existing roads. Even more, that Darkmatter version does not lead me to MAXIS subway view but I still stay in normal view, with great comfort for me :)
I really hate when I select a subway station and I go in underground mode! I always risk to demolish an existing building when I do so!

If you care, the reason for which I keep both is because I have already built 70% of my older cities with 2.1 and I plan to update all of then only when I will have CAM 2.0 and/or RTMT 4. Now I'm just collecting personal stuff to use later in february when I'll and a private research project about job satisfaction.... wanna join? :D

If I can mark another bug, I'm using the NAM2008-compatibile 5x-stops from RTMT 3.5 and I've seen that the description is wrong, since they do not match the true stops capacity, that goes from 2.500 for street bus stop, that are much smaller than RTMT 2.1 version,  to 42.000 for Avenue Sub+Bus stop. I haven't check the elevated train stop because I don't like them and wouldn't use them anyway.

PS: may I know what is the advantage of using el.train? (elevated, right?) The advantage of subway is that it goes undergroud and does not steal any place: the only reason from bringing it outside is because it is cheaper when the rail lines have to connect 2 far away places like 2 different cities, or to reach a specific rural place, as an observatory or hospital that is far away from the city core and there are no longer houses in the middle.


This sounds really strange, in my installation when I select ANY subway station the game always switches to subway view! Furthermore, I have checked Darkmatter's mod, and the Occupant Groups (which control such things) are identical, and exactly in the same order! I don't know, maybe other plugins affect this too!

The difference between the "catalog" capacities and the ones in the lots is intentional (check the readme for details), as the latter includes some extra allowance for the projected through traffic (it adds to the usage), while the catalog capacity is supposed to mean the "net" capacty.

The "advantage" of elevated light rail is only "aesthetics" - they are very common in american cities. Construction cost is lower too (though the cost of boring subway tunnels in SC4 is ridiculously low and unrealistic, real cities spend billions on these). Speeds are the same, but of course subways have the obvious advantage that they don't take space at surface level, and that the subway network can be designed independently, without interfering with the road network.


A few questions for people experiencing this problem:  When you select a subway station, do you all get Underground View (without buildings), or do some of you get Subway Station View (with buildings)?  You should be getting Subway Station View; if you're getting Underground View, that's the problem, as it's impossible to bulldoze anything other than subways and stations in that view.

Cogeo, just to confirm:  I gather that when you say "ANY subway station" you mean non-RTMT as well, and if so, I assume you've tried the Maxis station.  Do you get the Underground View or the Subway Station View?

Orion79:  Did you always have this problem with RTMTV3.5?  Or did it only occur after removing MML?  If the latter, did you do anything else to change your game settings?

Meanwhile, I did some more experimenting on my end.  I run Vista, and no one else had said what they ran, so I loaded my spare XP partition and installed SC4 + Rush Hour there.  I tried RTMT subways directly after the installation, after installing the patch, and finally, after installing the night lighting patch.  It worked every time for me.

If someone could try what I suggested, namely running a clean version of SC4 with only RTMT installed as a plug-in, the information would be very helpful.  This would seem to be an especially important test if non-RTMT subway stations are also affected.

Finally, it's my understanding that the version of this game sold in the UK and Europe is different from the US version.  Perhaps that's where the bug lies; that at least would be consistent with what appear to be cogeo's findings.  So which version of SC4 are you all using?  Finally, are you using SC4 Deluxe, or SC4 + Rush Hour?  They're supposed to be the same, but it's possible that they're not.

If we can't figure out anything more definitive here, I'll open this question to our testing group, and see what they can find out.


I think one of the good old data view mods changes the behaviour of the underground view. IIRC, Tropod said that there was no way to fix this. Try removing all those mods and see if there's any change.


Good point, Andreas.  I know of only one dataview mod that affects these views, and that's the one written by Tropod himself.  I installed it and ran SC4, and sure enough, I got the behavior that everyone is describing.  Instead of the Subway Station View, I got the Underground View, and I was not able to plop a station where there was already a road.

An easy way to tell if you have this mod installed is to look at your underground view.  If the subways are in shades of white and blue, then you've got it.  You can also search for the file itself; it's DataviewModd_RH.dat.

It's possible that there are other plug-ins that have a similar effect, and you won't see the colors in the underground view for those.  So if this isn't the problem, please try temporarily removing all your plug-ins except RTMT and see if the problem still exists.


You are right Andreas!

Searched my plugins folders and found... DataViewModd.V1.dat! A long forgotten plugin! Removed it, and it worked. Then tried installing DataviewModd_RH.dat and got the same problem.

Still, the "problem" isn't very serious anyway, as there is a workaround (the player can bulldoze the road tile first).