• Welcome to SC4 Devotion Forum Archives.

NAM Version 31.2 Now Available

Started by Tarkus, June 03, 2013, 08:46:52 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


After I installed everything and patch all the patch that is needed mine won't run.. when I double click the Sim City shortcut icon on my desktop nothing happens..

Prior to installing NAM.. it was running smoothly I reinstalled twice already and re patched..

still no good results.. any help?


Did the patch run successfully?  When you look at the executable, what's the version number on it?


I wanted to respond to the thread No Technical Support for Cracked/Pirated Copies of SC4, but it is locked, and I am sure there is a good reason. My copy is not cracked or pirated, but I was unable to re-install it after I replaced my hard drive, because I could not find the code on the box, but I was able to recover the executable off the old hard drive. For whatever reason though, now I am unable to install either NAM 31.2 or the patch 1.1.168. Prior versions of NAM did not tell me anything about that patch, and I guess I always assumed that I had all the patches I needed. One other possibility is that I moved my executable from where I had been running it with prior versions of NAM, and I need to update my registry accordingly. I have no problem putting down an extra $5.00 (I figured by now it wouldn't be too expensive), if I felt pretty sure that would fix my problem.


What error message are you getting from the NAM installer?  The exact wording would be very helpful.

In any case, installing a brand new copy of SC4 always works.

Indiana Joe

My key is located on the back of my manual, not on the box (even though the SC4 installer says it's on the box).  If you have a manual, check the back (at the top).


@Indiana Joe - Great suggestion. I will hunt down the manual.

@z - First it pops up a dialog which says "This program will apply EP1 update 1 (build 368) to Sim City4 (North America)

Next, it shows the Updating progress dialog, which says, "PATCH Version 6.50 - RT Patch(R) Professional
(C) Copyright Pocket Soft, Inc., 1991-2002. All Rights Reserved.

Next, a Patch Warning dialog pops up that says "Missing or Invalid Registry/INI entry".

Next, another Patch Warning pops up saying, "Old File does not exist"
It repeats this last pop up about 5 or 6 times before it pops up an RTPatch Binary Update System dialog saying, "Congratulations! Sim City has been updated with EP1 Update 1 (build 638)."

However, when I go back to the NetworkAddonMod Setup 31.2.exe, I still get an NSIS Error dialog that says that it cannot locate the executable, and when I direct it to the executable, it still says that I need this patch.  :'(

Indiana Joe

Keep in mind that you need an unaltered version of SC4 (not cracked) to update properly.


You need to add the registry entries for SC4.

If you have one, they should be easily obtained from a registry backup.

"We're making SimCity, not some dopey casual game." -Ocean Quigley


edit: sorry post wrong place


@jdenm: I'm not quite sure how to do that.

@indiana joe: It is not. I don't do that sort of thing.


The easiest way to add the registry entries for SC4 if you're not familiar with the registry is to reinstall the game over itself.


That's awesome.. 100% worked  &apls   ;D