LEX File Exchange
EA Support Files
SC4 Wikipedia
Network Addon Mod
Welcome to SimCity 4 Devotion. Please login or sign up.

August 18, 2022, 03:33:43 PM

Login with username, password and session length


Programs Incompatible with SimCity

Started by catty, April 12, 2013, 07:07:34 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hi Guys

Ran into something interesting while updating my downloads area (still working on it   :))

I recently had to replace my Win XP PC with a new Win 7 64bit computer and had SimCity 3 Unlimited working on it with no problems or tweaks necessary, went to check one of the files I was uploading to the CBEX and SC3K was no longer working, the splash screen would come up and that's it, after checking found I'd recently installed two programs for reading some user manuals as I've been having problems with the freezer at home, one was called

DjVu Browser Plug-in

and the other one I forgot to make a note of the name before I deleted it, once I'd un-installed both of them, SC3K was back working again   ()stsfd()

Now if it had been the other way around and I'd installed the manual reading programs before SC3K, I'd have probably assumed that SC3K couldn't be installed on a Win 7 64bit computer, which leaves me wondering if some of the problems people have with installing the SimCity games are less to do with hardware than with incompatible programs on people's PCs and whether there are any more programs out there that would stop SimCity working correctly.


I meant," said Ipslore bitterly, "what is there in this world that truly makes living worthwhile?" DEATH thought about it. "CATS," he said eventually, "CATS ARE NICE.


Catty this is a really good point you are making here.  I upgraded PC a while back to a Quad Core i5 and Win8 64bit.  When I first installed Windows I followed with the installation of McAfee antivirus.  Upon trying to install and play older games on my new PC I was finding I was either having issues getting programs installed, or the performance in the games was terrible.  I at first was assuming it was my major hardware change that had me experiencing these issues.  I wasn't receiving any error messages just failures, crashes, etc. 

I tried compatibility settings of all sorts, all to no avail.  I looked up tips for 64bit systems running 32bit games.  I searched for help with quad cores running single threaded games.  I looked for help on running games in Windows 8, which I thought was my second big problem.  I found all sorts of information to do this, and do that.  Some of these things helped a bit with some games/programs, but they all still had issues, most of which being poor performance; I expected better performance then I had on older PCs.

To sum it all up:  I eventually ended up in event viewer and found that every time I launched something McAfee was throwing all sorts of errors in my event log.  I was not running the built-in Windows defender simultaneously with McAfee, I checked that first.  So I uninstalled McAfee (all traces of it) and tried installing some of my games again.  Wouldn't you know the problem was McAfee all along.  All my programs were now installing and working great (sometimes using compatibility settings of course).  I have since abandoned 3rd party antivirus as the Win8 Defender and Firewall seem to be sufficient, now that it is a full featured antivirus. 

It seems to be between Win8 and McAfee in my case, not just McAfee causing this.  I use this same McAfee on 2 other PCs and games run great on them.  If I hadn't realized McAfee was doing this I may have drawn the conclusion that Win8 was bad for old games, 64bit systems are bad for 32bit games, or quad core CPU isn't good for old games.   If I had been forced to abandon playing my old games on my new PC that would have been heart breaking.  It's always good to troubleshoot as much as you can before drawing conclusions, and always use event viewer!



We can add OpenOffice Quickstarter to the list, I installed it a week or so ago, went to start up SC3K today and nothing happened, on the second attempt after logging the computer on and off and not being able to find any reason for it not starting, I left it and waited it took about 15 minutes to get to the splashscreen, about 5 minutes more to reach the menus, and another five to start a city, but then I couldn't do anything once I got there as it had frozen the city

After disabling OpenOffice Quickstarter and stopping it from automatically starting again, SC3K was back to a couple of minutes from hitting the start button to doing something in a city

I meant," said Ipslore bitterly, "what is there in this world that truly makes living worthwhile?" DEATH thought about it. "CATS," he said eventually, "CATS ARE NICE.


There might be an undocumented bug. Could you - or someone with similar computer and system - test if it happens with the new LibreOffice starter as well? I would appreciate this information.


Hopefully someone will turn up who can check this for you, if no-one has in a couple of days I'll download LibreOffice and see what happens

I meant," said Ipslore bitterly, "what is there in this world that truly makes living worthwhile?" DEATH thought about it. "CATS," he said eventually, "CATS ARE NICE.