LEX File Exchange
EA Support Files
SC4 Wikipedia
Network Addon Mod
Welcome to SimCity 4 Devotion. Please login or sign up.

July 03, 2022, 07:25:27 PM

Login with username, password and session length


Windows 10 and Terraformer

Started by noahclem, May 10, 2017, 01:16:30 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Does anyone have any experience running Terraformer with Windows 10? I recently got a computer with a 4K touchscreen, bought SC4 from gog today, and have been trying to get all of my SC4 tools to work. Reader, mapper, tweaker, and batch png-fsh work but terraformer, pimx, and datpacker don't, at least so far. I only really use terraformer to edit ground level below bridges and viaducts to accomplish things that wouldn't otherwise be possible but it's become a very important part of my current region with its canals and bridges. Any help would be much appreciated :)


Do you have MSCVP71.DLL - Some users may need this file. ( in case of error at startup ) It can be found here:
Kettle's on. Milk? Sugars?    ps I don't like Earl Grey  $%Grinno$%
Reduce, Reuse, Recycle - If you're not part of the solution , you're part of the problem!
"Never knock on Death's door: Ring the bell and run away! Death really hates that!"
Tales at TeaTime      Now A proper NUT      TTC plays GRV II


Thanks Derry! Unfortunately, it seems I already have all the .dll files listed in the readme. Will probably try reinstalling the whole thing but have a feeling that's not going to work either. Probably something really small that will seem obvious in hindsight :D  Hopefully I figure it out though, as it would be really annoying to have to switch between machines every time I want to make something float in midair.


I have win10 on a 1080p screen that works fine. Possibly its the 4k screen causing the issue as terraformer may not be able to support that resolution.
~ NAM Team Member


Have you tried with the Compatibility Tab in the File Properties setting the OS to Win XP or 7 or disabling Aero?
My creation at CityBuilders.

SimCity 5 is here with the NAM Creations!!


Compatibility mode shouldn't be required, since there is nothing within the code itself that prevents an application working with Win10. Similarly, disabling Aero shouldn't be required, it works with Aero on Win7/Vista just fine.

The main problem old applications tend to have with Windows 10 relates to changes in access permissions within the Program Files folders. Very often, the O/S simply won't allow files installed there to be modified, but some apps need to do this to function. In which case the solution might be to set the permissions for the folder to allow full read/write access (caution: potential security risk). Otherwise, you might find installng them outside of the Program Files folders makes a big difference.

The other issue exclusive to Terraformer comes from it opening an HTML file when you start the application. Sometimes this might not work and it causes issues. Go to the install dir and find "readme.html" and simply rename it. Then the app will think it's not there and skip this step, which may help. Beware though, Windows for the reasons stated may simply revert your changes instantly or not allow the change in the first place. Again requiring you to give full read/write access to the file/folder to make the change.


Thanks so much for the help guys! It says awesome things for our site that even in these slower days so much help is forthcoming within 24 hours :)

Unfortunately, I've still not gotten it to work. I've tried compatibility modes without success and now moved it to c:\games\sc4 terraformer and continue to have the same issues. Also renamed the readme file and tried running as an admin. I do have a suspicion now that the cause may be the folder being set to "read only". I've tried setting it differently but apparently windows keeps undoing my changes. Since I did a new "install" (well, just extracting the files I guess) to that games folder I'd hoped I wouldn't have that kind of problem that would seem more likely in the "program files" folder but nothing I do seems to be able to make the changes away from "read only" to stick. Might seem a silly question, but does anyone know why that's not working? Does it sound like the thing causing me these problems?

Thanks again for all your help everyone  &apls


In case there is a problem with write permissions, such old programs are usually installed into the "AppData" folder, which is hidden by default. Open your user folder (C:\Users\YourName) in Windows Explorer, then click "View/Options/Folder and Search Settings" (just guessing the English names), click on the "View" tab in the new window that opens, scroll down to "Hidden Files and Folders" and enable showing those. Close the window, and you should see the "AppData" folder within your user folder, create a new folder in the "Local" subfolder and install your program there.


Thanks Andreas :)

I tried that and unfortunately, it seems to be doing the same thing. I just get this message with the window titled "errors occurred": "See the logfile 'c:\users\noahc\AppData\SC4Terraformer.exe.log' for details"

It seems like no matter what I do I just keep getting the same stupid message. Don't see any logfile. I tried renaming the readme and running as administrator too but no dice.


Admin permissions are not enough to own it, the security in W10 is very locked down. BTW, quick way to access appdata, use the run command (Windows Key + R) and type %appdata% in the box and hit return.

For full access to a file/folder, take a look here.


I can get it to work with Windows 10 - the problem is that it is entirely unusable. Slow to the point of not even being practical, and the window is so small/unsizable that it's not even an option to use this program anymore. I love Terraformer but it is in desperate need of being tweaked for modern day PCs. I'm guessing that Terraformer was abandoned a long time ago (?)



Well, wounagaine hasn't done any work on it since the final NHP release which IIRC is stashed somewhere on his thread at Simtropolis. The SC4Mapper, iirc, works fine on Win10.

Given that other users have been able to open and use the program on Windows 10, it's likely related to a configuration issue; that is, Win10 isn't automatically choosing conditions that allow the program to run at full potential, and between that and the permissions management and other related issues (like, perhaps your graphics card isn't recognizing the program, and it's running off the integrated graphics?), getting it to run in a Windows 10 environment is much more difficult than it should be.

Terraformer is also more demanding than SC4. I can run SC4 on integrated graphics without too much fuss, but Terraformer brings my machine to a crawl if I try that; using the graphics card in that case is an absolute necessity, but one thing I've noticed is that nVidia (or AMD) doesn't necessary automatically recognize such programs as needing to use your graphics card to run properly.
Experience is something you don't get until just after you need it.

My Mayor Diary San Diego: A Reinterpretation


Good advice APSMS...

As for the window size, take it or leave it. Ultimately I think this was necessary for PCs to be able to run it with acceptable performance. It's a little annoying, but I'd rather work with that than in-game terraforming for the most part. In fact, my process is pretty much a combination of working with a greyscale image in Photoshop, tweaking it in Terraformer and in-game and switching between the three until I'm satisfied. Trying to create an entire region in Terraformer would be seriously tedious, it was never really intended to do that I suspect, even though you technically could.

Although Integrated cards (depending on the model), are nothing like as bad as they once were, you might have problems when using one. It really depends on your PC's configuration, for example how much RAM you have free and other factors. But there is nothing inherently wrong with the code or any incompatibilities with Win10 either. So if you are having problems, you should be looking at your system for the solution. Indeed if you've a modern dual-card graphics setup, you should enter the Control Panel utility and force the application to run using your dedicated board for optimal performance. Otherwise check your memory and CPU usage when running Terraformer (using Task Manager for example). This would show you if there was a general resource problem behind this.