Menu

LEX File Exchange
EA Support Files
SC4 Wikipedia
Network Addon Mod
Dependencies
Chat
Welcome to SimCity 4 Devotion. Please login or sign up.

May 24, 2022, 05:30:52 PM

Login with username, password and session length

Downloads

MGB's Mods and other stuff

Started by mgb204, May 04, 2015, 04:48:16 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Seaman

#300
Seriously, do you read minds?
Just a couple of days ago I thought: "hey, wouldn't it be amazing to have something like this?" And now it's here...  :thumbsup:

Thx for sharing!

Just a shy question. If I do already have your Filler Set v1, do I delete/replace it by v2 or are they intended to go alongside each other?

Unrelated to the above: I really like your underbridge set. I have a situation, where I have two 2-tile bridges next to each other, separated by a single tile median. Maybe you like the idea of adding lots with a 2-tile overhang or a lot that hangs over on both sides one tile, in case you are revisiting the release.

mgb204

Quote from: Seaman on February 22, 2019, 08:08:38 AM
Just a shy question. If I do already have your Filler Set v1, do I delete/replace it by v2 or are they intended to go alongside each other?

You should remove the original, since the IDs will otherwise conflict. Keeping the old ones could mess with the item ordering, icons and even mean you have the old lots which aren't as well modded.

QuoteUnrelated to the above: I really like your underbridge set. I have a situation, where I have two 2-tile bridges next to each other, separated by a single tile median. Maybe you like the idea of adding lots with a 2-tile overhang or a lot that hangs over on both sides one tile, in case you are revisiting the release.

Originally I only had the 1-tile versions since I figured by using two you could span a 2-tile bridge. You aren't the first person to request 2-tile ones for these setups, I'll see what I can do there.

Seaman

Thx for both answers. Keep it up :)

pontiff ofchrists

#303
Are those industrial streets available for download?

nvm, I didn't realize NAM includes them now

Alan_Waters

#304
Something seems to have gone wrong. Perhaps I missed something, but these two mods do not work quite correctly for me:
https://disk.yandex.ru/i/Z0P0bZ_jE-1yjg
https://disk.yandex.ru/i/DxvRK8eTvocEwQ
NAM version 43

mgb204

Sorry but those links aren't working for me, I've literally no idea what your problem is. Could you either explain the problem or post those images somewhere I can see them.

art128

I've uploaded Alan's picture on my imgur. I had to convert them though somehow as imgur was saying invalid file type on a jpg file...?


I'll take a quiet life... A handshake of carbon monoxide.

Props & Texture Catalog

mgb204

Thanks art128, I was just getting a black screen, maybe the site doesn't support Safari or something?

The first issue with the RHW barriers looks like you've perhaps installed both the Barrier and non-Barrier T21s, which may cause the barriers to move about as you click around. Make sure only one type is kept in Plugins.

As for the E-RRW, those textures should be covered by the RRW ReSkin I used to create it. It's important that this mod loads after the NAM folder, which if you've used the defaults it should. I'll double check those pieces too myself, maybe something went wrong and wasn't noticed before.

mgb204

Check you have the file RealRailway_Textures_DTR_ERRW.dat, it's part of the default install and has all the relevant E-RRW textures included. The screenshot attached shows it working fine for me so if it's there, perhaps you have a NAM file loading after it or some other mod interfering?

Likewise in the attached screenshot, you can see the effects of keeping both these files in Plugins:

     RHW Light and Barrier Mod for RH-6_8_10S.dat
and
     RHW Light Mod for RH-6_8_10S.dat

You should only use one set of three possibilities, for each supported RHW network, either:


  • RHW Barrier Mod for XXX
  • RHW Light and Barrier Mod for XXX
  • RHW Light Mod for XXX

From what I see in your screenshot, at least one of the outer pieces kept the barrier and a light, whilst the others didn't. This is what happens when you have multiple conflicting T21 files, essentially they will be overridden in the order shown above. But, because T21's are unique, often they don't override one another, but turn the T21s into a kind of 'Prop Family', where on or the other is chosen from every time a piece is refreshed.

The instructions cover what files need removing, so maybe check through it again and adjust your install as required.

Alan_Waters

#309
Thanks! I figured out the reskin; translation difficulties.  ;D
But with barriers it does not work very well. What should remain in the "LRMUSL Support" folder?

Because I only left the mod for barriers and light, but the problem remained.
Can the mod "RHW-6C_Steel_Barriers" somehow conflict with your mod?

I also found this:

mgb204

Quote from: Alan_Waters on December 27, 2021, 12:00:57 PMBut with barriers it does not work very well. What should remain in the "LRMUSL Support" folder?



Because I only left the mod for barriers and light, but the problem remained.

If you have LRM or USL lighting mods installed, only ONE of those files. If you aren't using either mod, you can remove the folder entirely. The readme details exactly how this works in more detail.

Note too that T21s like this don't automatically change, you have to click on the affected pieces to refresh the T21 data, that should fix up the barriers.

QuoteCan the mod "RHW-6C_Steel_Barriers" somehow conflict with your mod?

If any two mods both change the same pieces, then they will conflict with each other.

However there just may be another thing happening here, because that mod certainly isn't appearing in your screenshots at all. I'm thinking between the release date and the following information in the Mod's description:

QuoteThis mod is NOT compatible with the following mods: 
"RHW Lights and Barriers" from Xyloxadoria
"RHW 6C Mast Lighting" from Xyloxadoria
The RHW-6C/8C High Mast T21 files from
"High Mast Lights and RHW-6C/8C High Mast Light T21" from Blue Lightning

These need to be deleted in order to make this mod to work properly.

It would seem this mod was designed for the pre-P57 RHW ID changes, just as those mods that are mentioned as not compatible were. I've manually checked and indeed this is the case for all four of these mods. Essentially all these old T21 mods use an ID scheme that hasn't existed in the NAM for many years now (since NAM 30). In other words, there is no point in installing such mods at all, since they simply no longer work. Which is why they aren't actually showing at all on your RHW. As such they also don't conflict with my mod, because I've used the new ID scheme.

QuoteI also found this:

Provided you selected the option for the RRW Ramp override during install, you should have the correct file - RealRailway_ReSkin_MGB Ramps.dat. So if it's not updating, it looks like the RRW Ramps themselves are loading after the override file. You can fix this by moving the ReSkin file into the same folder where the file RRW Ramp_Resource.dat is, note you'll have to rename the file to zRealRailway_ReSkin_MGB Ramps.dat so it still overrides the original.

Alan_Waters

Thanks a lot! Everything worked out  :bnn:

simbot87

Im attempting to load a build txt file into GoFSH and it is coming up with errors.  The build file is from MGB's Repository on OneDrive.  Specifically I am loading "_OPT_Build 4_NGN Patch" but I have the other 4 builds from his OneDrive as well all with the same errors.  I have successfully loaded a build txt file for other mods but these from MGB are loading with errors.  Any suggestions?

mgb204

One problem I didn't know about (because I don't see it my end), is that when you download the repository it makes a .zip file, but this excludes any empty folders. This is rather annoying, since they are necessary for the scripts to work. You might therefore need to run the special .exe files 'CreateFolderStructure.exe' in both the _Install and _tmp folders, before all the scripts work as intended. Both of these are simply a .zip file converted into an executable (app) that extracts the necessary folder structure. So far as I can see on my end, everything is present and working, so I'm guessing it's some of these folders that are missing.