Sim City 4 Devotion Forums

SimCity 4 Devotion Custom Content Showcase => BSC Creations => BSC Place => Team Custom Content Projects => Daeley's Laboratory => Topic started by: bradf_50 on March 21, 2013, 03:07:32 PM

Title: Damn Menu Items in game greyed out
Post by: bradf_50 on March 21, 2013, 03:07:32 PM

Well I'm having a problem with the Damn Manager.
This is how it went:

Installed Damn
In game after install the three Icons/buttons showed up. They did not work. No other buttons showed.
Installed SSPTools, It would not run until I updated Java. After update of Java SSPTools worked.
Installed DAMN plugin.

After all three were installed I went back into SC4 and The Same three buttons/icons still did nothing. I was getting additional buttons/icons showing the default Damn stuff but they were ALL greyed out! The Damn and SSPTools seem to work just fine right now, I can add menu's and they show up but are greyed out in game.

I came here and followed some of the fixes that were listed here i.e. apps/, making sure the damn hidden folder loaded last zzzzzzzz_ etc. Also tried to change shortcuts to run as admin, and also set to run as Xp with sp2 & sp3. That didn't help.

Nothing has worked at all!! I don't even get the back, home, search buttons to work!

They all show up but all always greyed out in both the urgent and news windows.

So I'm at a loss right now.

Any Suggestions??

Title: Re: Damn Menu Items in game greyed out
Post by: jeremyp1223 on March 21, 2013, 03:29:23 PM
Did you install Damn in your installation plugins folder? It does not go in with all your other plugins, but into your plugins folder in your installation directory.
Title: Re: Damn Menu Items in game greyed out
Post by: bradf_50 on March 21, 2013, 11:24:22 PM

Yes I did install Damn in the SC4 install directory under plugins not in the My docs.
Actually that I checked early on. I checked all the paths for Damn, and SSPTools and they are all correct.

I forgot to mention that I'm running under Win 7 Home (64 bit).

I've been checking here for ideas of what I may have done incorrectly. But I have not as of yet figured it out.

I thought Things just got botched up some how so I uninstalled the Damn and SSPTools made sure nothing was left over and re-installed. No luck on that either.

I know it must be something really dumb because if I hit the open sub menu link the buttons will highlight but then grey out again.

So I'm still at a loss.

I have no idea at the moment as to what to try or check so I hope someone here can give me more ideas.


Title: Re: Damn Menu Items in game greyed out
Post by: Diggis on March 22, 2013, 02:44:07 AM
You don't have any news ticker disabling mods installed do you?
Title: Re: Damn Menu Items in game greyed out
Post by: bradf_50 on March 22, 2013, 10:06:19 PM
Hey Diggis

Thanks I checked it out and found a mod that lets me change the size of the window. I took it out but it didn't help any.

Thanks anyway.

At this point I may just back my plugins up and uninstall everything including SC4 and start over from scratch. If I do that I hope that fixes it!! If not I'll not be a happy camper. But if it does than I can re-install everything one by one and checking after every one to make sure Damn is still working. If not than I know it was the last thing I installed. I would hate to do this as I have quite a bit of plugins installed. But at this point it maybe something I installed that has Damn messed up.

I'm going to play around with it another day or so, than if I don't figure it out or someone figures it out for me than I'll go ahead and strip and reinstall.

If anyone has anymore thoughts/ideas let me know in the next couple of days.


Title: Re: Damn Menu Items in game greyed out
Post by: bradf_50 on March 26, 2013, 06:48:20 PM
Hey All Again

Well I gave it up for a couple of days, had some video editing to do. Anyway I got back to SC4 last night. For the heck of it I decided to start a new region. Not because of the DAMN problems but had other stuff I wanted to play with and decided to start fresh. Anyway I'm still setting the region up, transportation,and the such. Haven't got to do any zoning yet. But the good news is DAMN is working!!!! &apls.

I don't know why it only works in a new region and not in an existing one. I have 4 other regions going in some level or another and none of them the DAMN won't work. Only in the new region. I suppose I shouldn't look a gift horse in the mouth, but I can't figure why only in a new region, Can anybody else explain?

I'm still using the same mods, plugins and the such no change their. I was thinking seriously about doing a complete re-install of everything SC4 but now I think I'll live with it at the moment.

Anyway if anybody has a clue why this is happening let me know!


Title: Re: Damn Menu Items in game greyed out
Post by: bradf_50 on March 27, 2013, 05:46:38 PM

It's working but only I found out today it's not because of the region but the city. I started a new city today in an existing region and the DAMN worked. Maybe not as advertised though. Once you pick an item off the menu it greys everything out. Can't use the menu till I hit the link at the bottom about opening submenu. When I hit that it starts DAMN back up again. I think I read something about that here so I'll have to take a look at that later.

Now my question is,  is the DAMN suppose to work this way? I figure not since I can't find anything mentioning it. That is having to start a new city before the DAMN works that is!

Any help??