LEX File Exchange
EA Support Files
SC4 Wikipedia
Network Addon Mod
Welcome to SimCity 4 Devotion. Please login or sign up.

September 27, 2022, 09:00:53 PM

Login with username, password and session length


SC4Tool: Can't Save TE Lot?

Started by Aran, September 12, 2012, 05:04:28 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Run into a strange problem while working on a project.  I've got three lots, all created with SC4 PIM Extended and all successfully modded (in terms of stats, anyway) with SC4Tool.  I'm able to TE the first two lots without a problem, but when I load the third one the 'save' icon is greyed out.  I can TE the heck out of it, but not save it.  Anyone else run into this before?



Welcome to the forum and community Aran. Try removing the folder with your lot and dat files from plugins Sim City 4 and then work through SC4 Tool. I'm not sure that this will work, but you can try - good luck.


Thanks for the welcome and the quick response.  It didn't work.  I'm thinking it'll be quicker to rebuild the lot from scratch instead (it's a tiny 1x1) but would be interested if anyone else has any ideas.  I've been playing around with SC4T for the better part of a week and this is the first time it hasn't worked.



Most likely the lot has no base textures though I had SC4Tool acting weird for no apparent reason as well. You're right, best thing to do is rebuild the lot.
time flies like a bird
fruit flies like a banana


It has the same base texture as the other two lots as well as its replacement.


Yeah, sometimes SC4Tool just refuses to save, dunno why that happens. &mmm

And for future reference, if you made an elaborated lot which you don't feel like rebuilding, just quickly make a dummy lot with the appropriate dimensions and TE it. Next, in the Reader, copy the LotConfigProperty lines that start with 0x00000007 from the dummy lot and paste them into the real lot.
time flies like a bird
fruit flies like a banana


Good to know I can copy/paste that sort of thing.  It was a small enough lot that I was able to remake it in ten minutes, though, and the remake worked with SC4Tool.  It's all moot unless I can work out the automata issue from the other thread, though.   &mmm

I just wanted to make sure this wasn't indicative of a larger problem with SC4Tool.