• Welcome to SC4 Devotion Forum Archives.

Trees Conundrum

Started by evarburg, September 05, 2018, 09:42:46 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Way back then, I made myself some cheaty Power trees using craig-abcvs power tree lots. I used only girafe greenery in them. I have had no problems with them when on my WORK Plugins folder.

But when opening the game with my TEST P.Folder (only the lots and their deps) I get this :

But the exact same tree deps are in both folder ; there is NO other greenery that girafe's in those lots.

In the process of trying to understand this, I suddenly realized that I had two folders with girafe trees in my WORK P.F., because at some point they were re-uploaded and I re-DLed them, just-in-case. But I dezipped them on my MAC, not on my Window partition and they show up with "Install-bla-bla-bla" and a string of numbers, no more information, i.e. no way to know at first glance what is what. When I examined my lots in the L.E. I saw that many were from that re-DLed VIP-Girafe Folder -- for instance :

and I thought maybe it was the reason for the boxes. I tried to use the 'Install...number string" when indicated. Still, boxes.

And (last test) the trees in the first picture have been plopped WITHOUT that folder exactly as the boxed trees in the second picture !

I just can't find an explanation (or a solution) for this. Could someone help me, please ?


Well, I tried to remove that post but this doesn't seem to work anymore. Anyway. As usual, explaining the problems somehow helped me think it through : there WAS a dep missing : craig's power blank model --which apparently must be somewhere in my WORK PF, unbeknownst of me. (slinking away in shame.)

EDIT : Well, actually, no, the craig power blank model is nowhere in my WORK Plugins Folder -- and my power trees work ; but I must add it to the TEST Plugins Folder for them to work. Agaah, agagaaaaah, I'm going bonkers.

But they do work. I'll try not to ask why. However if someone has an answer, please feel free to share (it will spare me some "Why, but WHY ?"insomnia down the line...)


Find and open the Buildings Exemplar for your lots using iLives Reader. Go to the field Resource Key Type # (# is probably 1, but can be from 0-5), double click the property and assuming you have three reps (RTK # = 1), change each to 0x00000000 by simply typing 0 in each box.

Now the buildings on the lot points to a null key, i.e. a non-existent model, but unlike a missing model, null keys just make the building invisible. I.e. no chance of brown boxes and now there is one less, probably rare, dependency and your lots too. Not to mention, this is simply a better method of modding IMHO. Repeat for each lot, you may need to re-plop them to show the change.


Thanks, Robyn ! I had given up on understanding -- not that I really understand how your advice explains the problem I've encountered, but I will apply it faithfully. I Trust You.  ;D

EDIT : I must do something wrong (as usual) : adding a 0 to two of the rep. transform them into an 0XFFFF something --but not the third one, which stays unchanged. And the plopped trees (without Craig's Power Blank) show up again with the BBB.

PS : Nevertheless, I still trust you !  :D


A little bit more of the technical side of this (Robyn has probably in-fact explained this elsewhere):

Every Building (or prop) Exemplar includes a Property titled Resource Key Type (abbreviated as RKT) X (where X can be a number from 1 to 5, with each number having a specific meaning).  Usually for Buildings the property is RKT 1.  The value for this Property is the TGI for the model used for that building.

The problem you are experiencing is caused by process used by creators of especially the earlier custom content, whereby, instead of just creating a new Building Exemplar from a specific model, they would instead create a prop using that model, and then use a blank model for the RKT property in the Building Exemplar.  This process was often used (and is still used) where a lot may include multiple buildings, and a content creator wanted to create a Building Exemplar for the entire lot (for example an industrial site).  This was no problem as long as the TGI used in the RKT property was the one for the blank model included with the game.  However, some creators felt a need to create their own (thus creating a new dependency), while others I suspect just created a nonsense TGI.

If I understand Robyn's solution correctly, one tells the game to disregard the TGI in the RKT property by changing all the numbers to zeros (0), i.e. a null key.  The game looks at the null key and just disregards this value, and alleviates the brown boxes that would otherwise occur if the game couldn't resolve the configured TGI (this may not have been understood early on, or may just have been the way to go for this type of lot).

This would be a much faster solution than trying to find the blank model created by the content creator (or someone else's), or going the longer route of just creating a new Building Exemplar directly from the model (if you are relotting the model anyway..., but I understand the impulse to just use the existing Building Exemplar).

BTW, if your lots are working correctly in either of your Plugins folders, did you try scanning with DataNode to see what the lot is actually using?

Hope this hasn't created more confusion.  I know it took me while to figure out what was going on back when I first experienced this.


Quote from: evarburg on September 07, 2018, 09:47:09 PM
EDIT : I must do something wrong (as usual) : adding a 0 to two of the rep. transform them into an 0XFFFF something --but not the third one, which stays unchanged. And the plopped trees (without Craig's Power Blank) show up again with the BBB.

If you are getting 0xFFFF something, that's not what we need. A null key is basically 0, but we need to express this as 3 values not one, i.e. 0,0,0. But it gets more complex, because SC4 works in 8-digit hex codes, it also likes the 0x prefix. So we end up with the following values:


or Values as Text:


Either of these will be considered a null key for the purposes of linking to a model. I.e. the game knows to simply disregard it, so no model appears, but it also doesn't show a brown box.

P.s. my name is spelt Robin ;)


... So... I should enter them manually, not just add a 0 to whatever rep is there, I guess.

(And oops, sorry, Robin.)


Yeah, basically you have the "Reps", where each number is listed vertically. If you just type 0, when you press TAB to switch to the next box (also possible with the mouse), it will change that to the 0 SC4 likes, 0x00000000. In short, it's just quicker than putting the entire hex code in manually.


(was away...) Thanks for the added info. I'm into something else at the moment, but I keep all advice in my HOW TO box ! :)