Menu

LEX File Exchange
EA Support Files
SC4 Wikipedia
Network Addon Mod
Dependencies
Chat
Welcome to SimCity 4 Devotion. Please login or sign up.

July 07, 2022, 06:48:48 AM

Login with username, password and session length

Downloads

NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE

Started by jahu, June 03, 2007, 10:15:49 AM

Previous topic - Next topic

0 Members and 2 Guests are viewing this topic.

Andreas

Quote from: BigSlark on July 18, 2007, 05:10:26 PM
So...I have Frogface's 4-track Modern Station installed, the GLR patch installed, and the draggable GLR installed as well. I get the "brown box" and the icon doesn't display in the Misc Transit Menu.

However, it does work when I plop it from the rail menu as a railroad station...

Anyone have any ideas?

IIRC, there is the original rail station, and then a GLR conversion that was released later. You need both of them (and the GLR patch, of course), otherwise it won't work properly.
Andreas

BigSlark

I have all three, Andreas, and the GLR station worked before the June NAM.

Bluebeard

Sorry if the answer is in this thread but wife wants the computer back.
    Download the NAM but it's not in the game menu.Oh I'm running Vista.Thanx for help.

Bluebeard

Ok I got NAM installed but not from SC4D LEX.Well I tried the LEX download but it appears either my computer don't like it or maybe the file has a itch.Thanx for the help. :)

Andreas

Did you install the proper file? Maybe you only installed the NAM Essentials - but you need the complete NAM installer, which is about 10 MB large. The current NAM Essentials are only necessary if you want to use the Rural Highway (RHW) Mod, or the custom bridges.
Andreas

Bluebeard

Thanx Andreas.
    You may right seeing how I am new to this Vista and my head is spinning trying to figure it out.Dang I miss my Win 98.

le_harv

I have a bit of an issue and it has been bugging me for a few days. I recently got back into SC4 so took out my plugins folder (to eliminate conflict) and installed the new NAM which I downloaded from the SC4D LEX a couple of days ago. I installed it following the instructions and readme but did notice that the installer looks to be from December 2006.



I proceeded through the installation and got to the part with the plugins so selected all of them as i wanted to use everything, i did notice there was no optional plugin for GLR/dragable GLR nor for avenue roundabouts or the road/rail smooth curves.



From there I downloaded the NAM Essentials File for June 2007 and installed that as per the instructions. I did not run cleanitol as i had no other plugins. I also installed the RHW Mod too.



Now i have read the readme and understand that things like the dragable GLR and avenue roundabouts are part of the NAM file so do not need to be downloaded separately? I do not have any in game shots so i will explain it as best I can...

1. The road curves exist within the puzzle piece menu but when placed nothing shows up other than 2 stubs where the ends of the curves would be. The description of the item in the menu shows an 'intersection string' missing. This is the same for the rail puzzle pieces.
2. The Avenue roundabout exists in the puzzle piece menu but when placed does not show up correctly and also says 'intersection string missing'
3. Finally dragable GLR is not located separately beneath the GLR puzzle piece icon in the menu structure as i have seen in other screen shots. Within the GLR puzzle pieces themselves there are 2 pieces that say 'intersection string' missing and i am pretty certain I the GLR puzzle pieces themselves have the old textures on them from a months back and not the new ones by Ebina that i see have been included in the June 2007 version.
4. The RHW does not appear when the two lines of ANT are drawn alonside each other. Textures do however appear under overpasses etc.

I am at a bit of a loss for what to do as I have reinstalled the NAM a few times and redownloaded to make sure i have the right version. Could someone please explain what i am missing? I am computer literate and know my way round a desktop, i even thoroughly read the readme!

EDIT:

On further review i see that I appear to be missing some files in my plugins folder related to the NAM. They appear to be the modular structure of the newer NAM?

Many thanks in advance.

Andreas

Well, it doesn't only look like you installed the NAM version from December 2006, but this is an old version (the date label is there for a reason). The most current NAM is from June 2007, and the NAM Essentials will only work with this version. Also, you only need to install the NAM Essentials if you also want to use the current version of the RHW (Rural Highway Mod). I suggest to uninstall the old NAM and delete the NAM folder(s) manually, before you install the most current version. I also suggest to run the included Cleanitol file before installing the new NAM.
Andreas

le_harv

Quote from: Andreas on August 07, 2007, 02:25:43 PM
Well, it doesn't only look like you installed the NAM version from December 2006, but this is an old version (the date label is there for a reason). The most current NAM is from June 2007, and the NAM Essentials will only work with this version. Also, you only need to install the NAM Essentials if you also want to use the current version of the RHW (Rural Highway Mod). I suggest to uninstall the old NAM and delete the NAM folder(s) manually, before you install the most current version. I also suggest to run the included Cleanitol file before installing the new NAM.

Thanks for getting back to me. Its nearly impossible for me to have that old version of the NAM because I never previously downloaded the NAM from January 2007. The screenshots of the installation file have come from the one i downloaded from this link here....

I thought the problem might have been an older version of the NAM but I am adamant that I have downloaded the correct one from this site. I have the June 2007 NAM Essentials file and the latest RHW files. Are their other locations to download the 2007 NAM? Each time i reinstall i manually delete every NAM file by hand.

I will try the other things u suggested. Thanks...

Andreas

Hmm, I don't know about that link, but the most current NAM was uploaded to the LEX. It can be found here: http://sc4devotion.com/csxlex/lex_filedesc.php?lotGET=851
Andreas

RippleJet

That is in fact the file you download if you go to the page linked to from NAM 2007 in the header of the SC4Devotion homepage.

Seems like Jeronij needs to correct that download...

le_harv

Andreas

This looks more like it! Thanks for the help.




Ripplejet

You are right i think that link points to an outdated file. I thought the date on the installer was a bit old.


Thanks for the help again, much appreciated.

RippleJet

Quote from: le_harv on August 07, 2007, 02:52:11 PM
You are right i think that link points to an outdated file. I thought the date on the installer was a bit old.

Thanks for the help again, much appreciated.

Thank you le_harv for pointing out that outdated version! ;)

Bluebeard

Thanx to the Goddess I am here.
   Ok my problem for today is the Avenue GLR.
You have a Avenue running North to South and another running East to West.Now when these 2 intersect I havn't found the proper puzzle piece.
   So is there a Puzzle Piece for 2 Avenues that intersect?.A pic is appreciated.Thanx :)

Shadow Assassin

There is. It's in the Avenue GLR rotation ring. Just keep on pressing Tab till it comes up. It should be somewhere in there.
New Horizons Productions
Berethor ♦ beskhu3epnm ♦ blade2k5 ♦ dedgren ♦ dmscopio ♦ Ennedi
emilin ♦ Heblem ♦ jplumbley ♦ moganite ♦ M4346 ♦ papab2000
Shadow Assassin ♦ Tarkus ♦ wouanagaine
See my uploads on the LEX!

Bluebeard

Thanx Shadow but I have Tab till my fingers hert but thanx for the help. :)

BigSlark

Bluebeard, shift+tab reverses the loop...so if there's a piece you want at the end of loop, it only takes hitting the keyboard once, instead of twenty times.

Cheers,
Kevin

mightygoose

i cant get euro road textures to work with the new NAM... is there any particular version i must use ? aqnd where exactly do i put them. i havent had problems with previous NAM's but i thought i'd clarify...
NAM + CAM + RAM + SAM, that's how I roll....

Andreas

The Euro Road Textures Mod (ERTM) has to be loaded after the NAM. IIRC, the original installer uses a path like \NAM\ERTM. Since the NAM folder strucure has changed, try to add a "z_" to the ERTM folder, so it's loaded last. Also, I haven't heard from frimi since a while, so currently, there are no Euro textures for the new NAM items so far.
Andreas

mightygoose

NAM + CAM + RAM + SAM, that's how I roll....