• Welcome to SC4 Devotion Forum Archives.

SC4Tool has stopped working

Started by nPr, April 04, 2011, 07:12:02 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I have been having this problem only this year (at least after months of not being used).
The SC4Tool would not start at all, giving me the notification, "SC4Tool has stopped working. Windows is checking for a solution to the problem."

A year ago, it was up and running, having no problem as far as I could remember. I'm still using the same computer as now. I tried reinstalling the SC4Tool but with no success. Anyone have any idea on how to solve it &mmm? I did not do any major changes to the computer e.g. re-install OS, re-format, etc.

Compatibility is set to Windows XP (SP3), run as admin, and disabled the aero theme.



A few months ago, Microsoft relased a Windows update that causes problems with the FSHlib.dll. I've updated the SC4Tools installer with a new version of said DLL, provided by null45. If you don't have this version, you might want to install it and try again. Other than that, the only compatibility setting that is really needed is disabling "Desktop Composition".


May I know where I could get the latest version? I tried downloading the installer again today from Sim City Kurier, but the installed SC4Tool with it still have the same problem.


The file from SimCityKurier ist the latest one. Unfortunately, I don't know what could cause the problems that you described. Anyone else having problems?



I googled troubleshooting for Sc4Tool and found this thread.  Hopefully you can help me out. :) 

I am having a similar problem.  I recently DL'd the SC4Tool, and it loads up fine, but whenever I click on a menu item ("File, "Open", etc.), the program freezes up for about 1 minute, and then is non-responsive.  Whenever I try to do ANYTHING, it just freezes up. 



Did you try what I suggested three postings above (disabling "Desktop Composition")?


I am having the same problem as tommerbob. I will try what you suggested.


Quote from: Andreas on April 16, 2011, 02:42:31 AM
Did you try what I suggested three postings above (disabling "Desktop Composition")?

Oooh it worked!  Sorry I missed that last sentence in your above post.  Thanks a bunch. 


I have a similar problem with this program after instal on Windows 7.
Naturally he is fine after I turned the Deskstop composition, but I noticed something pretty unpleasant - safes do not work. I give to save a value and everything looks fine until you open the program again and everything is a primary value.
This is extremely frustrating since I in fact can not edit any files. Please help me with some solution.


I had it working perfectly on Vista until MS did an update about 4 or 5 months months ago.
Now it tells me its side by side configuration is incorrect. A fix would be greatly appreciated.
I hate MS.

It took me a bit but I simply did an uninstall and a new install with patch and it works fine now.
Many, many, many thanks for the creation of this great tool.

I still hate MS.
Freedom is never free.


For me it works well after I disable Deskstop composition, but this damn problem saving me crazy. I successfully safe any change in value, but once I quit, and then I restart the program: the value is the old numbers


I have the same problem as others have at with SC 4 tool "freezing".
I use Window 8 and according to Microsoft Desktop Composition can't be disable.
"desktop composition is a core operating system component and cannot be disabled. With a few exceptions, desktop composition is always on; it's started before the user logon and remains active for the duration of a session. "
Any help would be most welcome, thank you.

Indiana Joe

I've never gotten SC4Tool to work on Windows 8 either.  I don't think they're compatible.

I've noticed Windows 8 has made a lot of previous compatibility features inaccessible (for example, something that's been driving me crazy: you can't run Internet Explorer, or any browser, in 64 Bit mode).  Fortunately my main computer has Windows 7.  I think I'll be keeping that OS around for a while.


Has anyone been able to get SC4Tool to work under Windows 8?  If not, does it run at all?  Even being able to use it in a "read-only" mode would be quite useful, as I could at least see what the transit switches were.

Also, any info about how other tools for SC4 perform (or don't) under Windows 8 would be greatly appreciated.


Running as an Administrator runs okay on my machine, the only issue is occasional crashes, however I also experienced them back on Windows 7.


Quote from: samerton on August 11, 2013, 02:18:17 PM
Running as an Administrator runs okay on my machine, the only issue is occasional crashes, however I also experienced them back on Windows 7.

Oh, good.  Now I can upgrade to Windows 8 when it becomes necessary.  And SC4Tool never crashed for me under Windows 7, so I may be in luck on the stability front, too.  Thanks, Sam. ;)


Yes I know its been long time since this thread was posted in and thank god for reading about disabling Desktop Composition.... I was about to post for help as it seemed that running Sc4Tool would lagg, like take forever to open a menu.... I literally just disabled the desktop and boom working like a charm

Don't forget the SC4D Podcast is back and live on Saturdays @ 12 noon CST!! -- The Podcast soon to Return Here Linkie