LEX File Exchange
EA Support Files
SC4 Wikipedia
Network Addon Mod
Welcome, Guest. Please login or register.
Did you miss your activation email?

May 08, 2021, 03:17:55 AM

Login with username, password and session length

Author Topic: Models not showing up in PIMX  (Read 874 times)

0 Members and 1 Guest are viewing this topic.

Offline evarburg

Models not showing up in PIMX
« on: October 06, 2019, 12:45:02 PM »
Wanting to make CS growables into ploppables, (custom lots), but the models are not showing up anywhere in PIMX though the lots do where they should.  Could someone tell me why those models wouldn't ? [they are Japanese lots, for instance see :

(it's been a while since I did that, so remind me : I do need to drag a model to the relevant category in the left column, yes ?)

Offline twalsh102

  • Forums Councilmember
  • *
  • Posts: 108
  • Total likes: 86
  • Reputation: 2
  • Your slogan here
Re: Models not showing up in PIMX
« Reply #1 on: October 07, 2019, 12:37:57 AM »
I'm not sure what might be happening to you.  I downloaded the .SC4Model file at the link you posted, opened PIM-X, and was able to find and see the model.

While I know you aren't stupid, I think all of us have one of those Homer Simpson-esque "Doh!" moments from time to time (it seems to be getting more frequent with age).  I would like to go down a short checklist to verify that some simple mistake wasn't overlooked:

1.  Downloaded .SC4Model file (was a separate file at the link referenced)?
2.  When opening PIM-X, you checked the necessary subfolder where you saved the .SC4Model file (remember that PIM-X requires you to check not only Plugins, but also each root-level subfolder you want it to browse)?
3.  When PIM-X opens, you looked under Standard Models (remember that PIM-X doesn't default to showing you items in any particular order; I always click on File - this will sort all custom content to the bottom of the list)?
4.  Sometime if there are foreign characters in the file name, a program may not be able to read it. 

Offline evarburg

Re: Models not showing up in PIMX
« Reply #2 on: October 07, 2019, 10:21:26 AM »
(I love your diplomatic approach  ;) )

(0) re the Japanese character. You may have notice, if you used the lot I sent, that there are no Japanese characters left in the titles or on the files (and there are none, of course, in the jmh files).
(1) I use a completely empty plugins folder, only the lots I am testing
(2) check Standard models, OK nothing ; check Other models : nothing gobanboshi, only a blank that goes with the Steam version of the game, O...K...
(3) check Descriptors/Commercial Service/CS Low Wealth :  gobanboshi lot shows up (with picture inn left box ; which keeps up showing up if I click on any other descriptor, industrial, agricultural or whatever but it might be normal, I don't know -- not really used to PIMX)
(4) it also shows up in Lots/Stage1/CS -- ditto for the picture with stays on wherever I click along the list
(5) check in All Others : no show.
(6) I also notice that another model I put in there, just to see if there was something wrong with the gobanboshi one does not show up at all (jmh_CSSI-0x5ad0e817_0x72c3911f_0x30000.SC4Model) ; only the Lot and the .desc.
(7) if I try to drag anything (to Landmark/CS1), I get an error message (which may be normal since none of the files dragged is a model...):

 [Traceback (most recent call last):
  File "SC4PIMApp.pyo", line 3136, in OnBeginDrag
  File "SC4Data.pyo", line 50, in __getitem__

(8) tried the whole thing all over again with a randomly selected growable lot (Zero7 Banco) : same result
(9) only thing not tried is reinstalling PIMX ; but before that... :

(10) [“image... words...”] could you show me a picture of what you are seeing in your PIM ?
« Last Edit: October 07, 2019, 12:15:09 PM by evarburg »

Offline evarburg

Re: Models not showing up in PIMX
« Reply #3 on: October 07, 2019, 12:17:37 PM »
Well, I reinstalled PIM and now it works. &hlp


(hm, should that be the default position when a tool doesn't work as it is supposed to, all things being considered ?)

Offline Andreas

  • Administrator
  • Forums Legend
  • *
  • Posts: 4791
  • Total likes: 1015
  • Reputation: 33
    • SimCityPlaza
  • CL: ()bobby() Transit Controller
Re: Models not showing up in PIMX
« Reply #4 on: October 07, 2019, 01:57:59 PM »
Well, usually, a program doesn't stop working suddenly when you didn't delete any file from the installation folder on purpose or something else. But since you often had various troubles with the game or some of the tools, and reinstalling "magically" fixed it eventually, I still wonder if your computer (hardware/operating system/whatever) is damaged somehow, breaking things silently over the time...

Offline evarburg

Re: Models not showing up in PIMX
« Reply #5 on: October 07, 2019, 09:44:46 PM »
like I said : I don't want to know !  :) But seriously : I'm not sure I really need to. When I've had trouble with SC4 software in the past it was either because something was missing in it that I didn't know about and when I added it, it worked (with PIM, for instance, eh) ; or  I had done something wrong, like putting something in the plugins folder that shouldn't have been there, most likely, and it screwed things over. When I reinstalled PIM this time, one of the patches was already in, but not the other one -- so maybe that was it.

And if it's my computer software that has become malignantly sentient and is breaking things behind my back, I don't want to know !

(Cue The Ostrich Song)